New Post isn’t showing up in Sitemap

  • The last post has been published 72 hours but it’s still not showing up on sitemap. Google search console has indexed the post under – indexed but not submitted in sitemap category.

    I am pretty sure that there is no caching issue.

    • This topic was modified 6 days, 16 hours ago by Shanto.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    If you already had previously indexed those URLs, Google has them already so it doesn’t need to index them again using the sitemap (and that is why you would be getting the indexed but not submitted from the sitemap). You can read more about it in the Google’s official forums here: https://support.google.com/webmasters/thread/3799738?hl=en

    Looking forward to help you.

    Indexing isn’t the issue here. The new posts aren’t showing up on sitemap_index.xml

    • This reply was modified 5 days, 13 hours ago by Shanto.
    • This reply was modified 5 days, 13 hours ago by Shanto.

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    If you have any caching plugin, please exclude your sitemap URLs from caching and purge your site cache then do the following:

    1. Head over to WordPress Dashboard > Settings > Permalinks

    Hit the save button once.

    2. Go to WordPress Dashboard > Rank Math > Sitemap Settings

    Hit the save button once.

    That should fix the issue.

    You can test your sitemap in a private browser to avoid browser caching.

    If the issue persists, please do let us know so we can look at this further.

    This method didn’t work.

    I’ve fixed the issue by disabling the sitemap and then re-enabling it. Now I see the new post showing up on sitemap.

    But I don’t know if it has been fixed permanently or not. I can’t disable & then re-enable every time I publish a post. That’s pathetic!

    Hello,

    This is only needed when you make substantial changes to your website. This is not just with Rank Math, it is a core WordPress requirement to flush rewrite rules when something substantial changes related to rewrite rules.
    https://developer.wordpress.org/reference/functions/flush_rewrite_rules/

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

Viewing 5 replies - 1 through 5 (of 5 total)

The ticket ‘New Post isn’t showing up in Sitemap’ is closed to new replies.