My Products Pages and Posts are not Indexing In Google Search

#126081
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    Thank you for contacting Rank Math and bringing your concern to our attention. I’m sorry for the delay and for any inconvenience this issue may have caused you.

    Could you please check the following:
    1. Is the sitemap working fine in your browser? You can check that by going domain(.)com/sitemap_index.xml

    If the sitemap is working fine, you can try validating it on this link: https://www.xml-sitemaps.com/validate-xml-sitemap.html

    If the validation works, please move to the second point.

    2. Have you verified the correct version of your website on Google? Please check if you have verified the www (or non-www) and https (or http) version of your website. If there is a mismatch, please fix that.

    3. Finally, make sure you have cleared the cache and excluded Google bot from seeing a cached version of your sitemap.

    If you have followed these and you can view your sitemap without any problem, then Rank Math is outputting your sitemap correctly, and the error must be coming from Google. You can try and use a 3rd party sitemap plugin to confirm. Just make sure you have disabled the Sitemap module of Rank Math in WordPress Dashboard > Rank Math > Dashboard when using a 3rd party sitemap plugin.

    If the other plugin works, please do let us know.

    I hope that helps. Thank you, and looking forward to your update.

    Please check this screenshot @ https://ibb.co/BPjJmTJ

    I’m getting “Noindex” tag error, but I checked, there is no Noindex tag on the page.

    Here is the link to the page @ https://naijatechclan.com/brand/infinix/

    And please what do I need to do so my posts will rank in the google search engine?

    Hello,

    I checked your page and I can confirm it is set to index, here is a screenshot: https://i.rankmath.com/0WCw5q of the test using this tool: https://smallseotools.com/meta-tags-analyzer/

    From your screenshot, it seems that your page has not been crawled/updated recently. Given the page is already in the sitemap, could you please try validating or inspecting the URL again to see if it gets crawled and the meta updated again.

    Let us know if this helps.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this ticket.