muteyaar.com Missing field ‘Image’ problem with URLs and Sitemap Noindex issue

#480474
  • Hi,
    my website http://www.muteyaar.com has some issues that I suppose just came when I updated rankmath.

    Many of my URLs are indexed on google but are not showing in Google Ads / shopping because of the problem of MISSING FIELD ‘IMAGE’.

    Also, my sitemap is not indexed on google search console as it is marked as ‘noindex’ detected in ‘X-Robots-Tag’ http header.

    Kindly help me out on this issue and oblige.

    thanks in advance,
    virpal singh

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello,

    Thank you for contacting Rank Math, and sorry for any inconvenience caused.

    1. Can you please share a few affected URLs so we can check?

    2. The sitemaps, by default, are set to noindex as it is not meant to be indexed and appear in the search results.

    The sitemap should only be submitted in the sitemaps sections in the Search Console.

    Please submit the sitemap in the sitemaps section by following this guide:
    https://rankmath.com/kb/submit-sitemap-to-google/

    Hope this helps.

    Thank you.

    Thanks for the reply and clarification on sitemap.

    Here is a sample URL: https://www.muteyaar.com/tumbi

    This URL has Missing Field ‘image’ issue in LIVE URL Test in google tester.

    I do not understand why google is giving this error…

    Hello,

    I’ve checked the product, and indeed it is getting the Missing field "image" error.

    In this case, please ensure that the WooCommerce Product schema is already applied to it and clear your website/page cache.

    Once done, try testing again using Google’s Rich Results test tool.

    Let us know how this goes.

    Thank you.

    Thanks for the quick resolution.
    I did add the woocommerce product schema in this particular product page and it worked smoothly.

    Now, I want to add this to all of my products and I have over 2400 products in my store.
    How can I add the woocommerce product schema to all my products globally? Is there a way to do this universally from Rankmath settings?

    Or will I have to add this one by one to all the products?

    Hello,

    The WooCommerce Product Schema should be applied to your products once you have set it as a default in Rank Math > Titles & Meta > Products > Schema Type:

    WooCommerce None

    Hope that helps.

    Thank you.

    This setting is already done since long time, but I am still getting the schema generator button in product listing.

    Kindly see these two screenshots:

    https://prnt.sc/oFqR8FiNzwNF

    https://prnt.sc/QpQoF2Rs1-qL

    Hello,

    Switch the default Schema for your Product pages to “None”, save the settings page and reload the page. After doing so, set it back to “WooCommerce Product” again.

    If the issue persists, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress login in the designated Sensitive Data section.

    Please do take a complete backup of your website before sharing the information with us.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    I tried switching to NONE and then again switching to Woocommerce Product.

    Now, The default setting has been updated correct only for the new products that add to my store.

    But the old products setting is still showing the schema generator button.

    Hello,

    In this case, we have a feature to apply the default schema type to your products in one click:
    https://rankmath.com/kb/bulk-editing-in-rank-math/#set-schema-markup-to-default-type

    However, that option is only available using Rank Math PRO.

    If you wanted us to further investigate this issue, please follow the steps above and include the logins in the sensitive data section.

    Looking forward to helping you.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this ticket.