Missing field ‘logo’ for publisher details in rich results

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi Yes, i am facing the same issue.

    I solved it by switching off schema in rank math and using another plugin for schema. Rank math definitely has some issue with schema markup.

    • This reply was modified 6 days, 7 hours ago by Vinod.

    I fixed the issue by reverting RM to 1.0.47.1. Far from ideal, but breaking rich results is also far from ideal.

    As far as my testing has shown, this issue has existed since 1.0.48. Please get on this RM, I have lost all of my rich results over this bug.

    Same issue here. I’ve tried everything. I’ve also rolled back to 1.47 and now it’s working fine again.

    This ticket sounds similar but version 1.50 hasn’t fixed anything for me.
    https://support.rankmath.com/ticket/amp-page-is-giving-structured-data-error/

    • This reply was modified 5 days ago by Mark.

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    The issue was fixed within version v1.0.48.2, please update and let us know if the issue persists.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello Michael,

    It clearly wasn’t fixed then. As I stated in my previous message, I only fixed the issue by reverting to 1.0.47.1. I tried every other option in the rollback settings.

    Both of my sites that use Rankmath were 1.0.50 (which was latest at the time) when I first noticed the issue. I first rolled back to 1.0.49 and the issue persisted. I tried every version and the issue was only removed with version 1.0.47.1.

    Mark also stated in his response that he was on 1.0.50 before. The issue seems to exist on every version after 1.0.47.1.

    As Ethan says, this is not fixed. I’ve tried all version up to 50 and they all break. 1.0.47.1 is last correct working version. I am using Astra theme with AMP official module.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this ticket.