Missing field “itemListElement”

  • I was getting “Missing field itemListElement” error on Google Search Console for my site’s tags and parent category pages. It was like below:

    "itemListElement": []

    Issue is solved after activating the “Show Homepage Link” option. Now it is:

    "itemListElement": [
    {
    "@type": "ListItem",
    "position": 1,
    "item": {
    "@id": "https://example.com",
    "name": "Example"
    }
    }
    ]
Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Thank you for sharing it! Then, do you want us to report it to the dev team? Also, after you fixed it, do you have any other issues?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hi, sure you can report this, with no other issues.

    Hello,

    It sound like you have enabled breadcrumbs to your homepage. Which URL were you having this issue? Could you please share in the sensitive section?

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi Michael, i was had the issue on tag and parent category archive pages which had no breadcrumb parent item.

    It’s better to have home link at start of breadcrumb. And we don’t want switch it back, because our pages at the approval stage on Search Console. Thank you.

    Hello,

    Please update to the latest release and clear your cache, let us know if this fixes the issue.

    Looking forward to helping you. Thank you.

    ​​​​​​

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this ticket.