missing ALT attributes

#54830
  • Hello,

    I have the same issue. I turned on ALT tags, but then if i go to my website and use inspector tool, I dont see the ALT tag (I clear my cache before so that I am sure I am loading latest update). Can this be fixed? Or am I doing something wrong?

    Thanks a lot!
    Martin

Viewing 5 replies - 1 through 5 (of 5 total)
  • Maybe important note: I am using Elementor page builder. Though I have read it should be compatible with Rank Math?

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you add your website URL to the Sensitive Data section so we can check it?
    ​​​​​​​
    Also, assuming you are using the latest version of all the plugins and the themes (please update if not yet), it could be a conflict with one of the plugins or the theme you are using.

    To determine that, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Please let us know if you find the culprit.

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Looking forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    To add the to the sensitive data: I have used already the Health Check plugin to rule out this option. I have also updated all plugins to the latest version.

    Hi Martin,

    I believe you are not adding the images using the content editor on the first link that you shared.

    It looks like that image is added by your theme using custom fields or hooks.

    Could you please try placing an image using the content editor and see if the alt is added to those?

    To clarify, Rank Math only adds the alt to images present inside the content and only if you add the content using the WP Editor – not via your theme or Custom Fields.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

The ticket ‘missing ALT attributes’ is closed to new replies.