Meta Title Issue

  • Hi

    I have an issue after switching from Yoast to RankMath.

    After switching to rankmath, many of my pages,post meta title, there’s an extra text “- Used Piano Malaysia” extra is coming?
    Screenshot >> https://prnt.sc/nql7v5

    However, I have not set that in my meta title settings >> https://prnt.sc/nql91n

    I also noticed other rankmath users are facing the similar issue in FB Group >> https://prnt.sc/nql9l8

    I have left the wordpress access in the sensitive data. Can assist to resolve this?

    Thanks

    How to resolve it?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    I have just inspected your page source and the meta titles are loaded correctly on the page as you can see here:
    IMG
    Please clear your site cache and resubmit your sitemap to Google.

    I hope this info helps. Thank you.

    ​​​​​​​

    Hi.

    I have resubmit my sitemap to Google long ago but it doesn’t work…

    If i post a new article in my website..it will show that extra text “Used Piano Malaysia”at the back of the meta title.

    I have not sure what is causing the extra text.

    I don’t have this issue when I was using Yoast plugin.

    Can you check?

    Thanks

    Hello,

    I see that the cache has been updated a while back:
    cache

    You just need to wait for Google to re-crawl and reindex your pages as the title is being added properly by Rank Math.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Hi.

    I don’t think its regarding Google re-crawling and reindex the pages.

    This is because i have posted a few new product pages in my website and got indexed but ALL the new pages still has the text “Used Piano Malaysia” at the back of my meta title.

    Here’s the screenshot what appears on Google >> https://prnt.sc/nqrxrj

    Here’s the screenshot of my settings >> https://prnt.sc/nqrzdp

    Please note that i am not the only one facing this issue
    >> https://prnt.sc/nql9l8
    >> http://prnt.sc/nqs03g

    Thanks

    Hi there,

    Thanks for the follow up.

    I don’t believe that the issue is theme related since I could not find any code that could be modifying the meta titles.
    I would suggest that you make use of the URL testing tool or request the indexing of one of the URLs from within the GSC to compare the results.

    I hope this info helps. Thank you.

    Hi.

    Sorry. I never mentioned it was the theme issue.

    Requesting index doesn’t make any sense. Because even on a new post will also cause the text “Used Piano Malaysia” at the end of the meta title BUT i did try to request it previously, it doesn’t help.

    This happens only after switching to RankMath.

    I have left my access in the sensitive data. Would be great if you can access to find the culprit.

    Hi there,

    Thanks for the response.

    Where are you replicating this issue on new posts, would you mind sharing the link since when I create new posts I cannot find the extra text on the page source code?

    I am looking forward to helping you. Thank you.

    Where are you replicating this issue on new posts >>> Recently I post some new products in the site. Here’s one of the url that shows additional text at the end of meta title >> https://www.mypianomalaysia.com/model/kawai-bs-2a/

    This is what shows up on google with additional text at the end of the meta title >> https://prnt.sc/nrfmdj

    This is the setup in rankmath >> https://prnt.sc/nrfn63

    Hi there,

    Thanks for the follow up.

    I have inspected the page source and the title looks correct on the link that you just shared as you can see here :
    IMG

    This is also how the page source looks like on the Google cache http://webcache.googleusercontent.com/search?q=cache:https://www.mypianomalaysia.com/model/kawai-bs-2a/&rlz=1C1CHBF_enKE797KE797&strip=0&vwsrc=1

    Please let me know if you can confirm this.

    Yes.

    The title is correct in page source but there’s additional text at the end of the meta title in google. >> https://prnt.sc/nrfmdj

    Thanks

    Please check if your actual SEO title matches the one you have set using Rank Math.

    You can confirm the same by opening the post and then following this image tutorial

    https://mythemeshop.d.pr/ePhMiA

    Once the source is opened, search for the word <title> and you can confirm if the title is the same as you entered in the plugin.

    If it matches as seen in the HTML source code there is nothing to worry about. Google sometimes does not honor your titles and displays them as per their will.

    You can go through this post on Google Search Console support section: https://support.google.com/webmasters/answer/35624?hl=en

    Specifically, you might want to check the title Why the search result title might differ from the page's <title> tag

    I went through this previously >> “https://support.google.com/webmasters/answer/35624?hl=en”

    However, it is very odd to have the “SAME” additional text “used piano malaysia” at then END of every new post now. This never happen when I was using Yoast plugin.

    I check the source code and everything seems fine.

    Have you access my site to check on the issue? I have left it in the sensitive data.

    Thanks

    Hi there,

    Thanks for the follow up.

    Yes we have gone through your site and everything is configured correctly.
    This issue will soon be resolved after Google has crawled all your site links since the changes have already been made on the page source.

    Please be a little patient this process take a while.

    Thank you.

    This issue will soon be resolved after Google has crawled all your site links since the changes have already been made on the page source. >>> The question is that I have posted new post and indexed which means Google already crawled to the site. However, there’s still additional text at the meta title.

    Is this a rank math issue?

    Hi there,

    No this in not a Rank Math issue. It takes a bit of time for all your links to be crawled and replaced on the Google web cache, you will notice that only the old pages exhibit this issue. I have tested your new posts including the one that you published 5 hours ago and the title appears correctly on Google.
    IMG

    Some of the links such as this one https://www.mypianomalaysia.com/contact-us/ was last crawled on 10 May 2019 01:52:14 GMT which means that the webcache is still holding old content.

    I hope this helps.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)

The ticket ‘Meta Title Issue’ is closed to new replies.