Meta doesn't show for a single post

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    Thanks for getting in touch with us today and sorry for the inconvenience caused.

    Google sometimes does not honor your titles and displays them as per their will. I have checked your page source and the correct meta is displayed as shown below:
    IMG

    You can go through this post on Google Search Console support section.

    Specifically, you might want to check the title Why the search result title might differ from the page's <title> tag

    I would suggest that you be a little patient and Google will soon update the meta once it has crawled your site.

    Thank you.

    Cool, thanks a lot I really appreciate the quick and clear response. Really liking your product. Have a great day =)

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/?rate=5#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)

The ticket ‘Meta doesn't show for a single post’ is closed to new replies.