Meta Description Is Not Correct

  • I have changed Title and Description Meta, but only Title is viewed correctly. And Description still uses old Meta. I was told it might be due to cache. So I did flush many times but still the same. I even tried to deactivate as many plugins as possible. It still gives the same result. When I check other websites, some give a similar result.

    I don’t know what has gone wrong. BTW I am not a programmer.

    If you can solve this issue, can you teach me? since a few more websites have the same issue.

    Previously I use All-In-One SEO and Yoast. I use Profit Builder as page builder for most of my websites.

    I also think I have similar issue with other sector of the website, not only Title and Description. I can see it in other website.

    • This topic was modified 3 months, 1 week ago by  Azizan.
Viewing 15 replies - 1 through 15 (of 18 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    It looks like server cache is enabled on your site. Any changes I am making on your site are not reflecting on the frontend. Even after deactivating Rank Math plugin, the meta tags were showing on frontend. Please contact your hosting provider and ask them to disable the cache. That should fix the issue.

    If that doesn’t help, please let us know. Thank you.

    ​​​​​​​

    Ok.

    I am using Litespeed server. Will contact hosting provider later,

    Hello,

    Sure. Please let us know once that is cleared or disabled so we can debug properly.

    Looking forward to helping you. Thank you.

    I will inform you guys. but not yet.

    I have got answers from both hosting provider and litespeed developer.

    They mentioned that the cache issue is not at server side.

    Hello,

    I see the cache issue is now fixed. I checked the description on page /pemakanan-sebagai-ubat-gastrik/, it is showing the correct description.
    Although, it looks like your theme or some other plugin active on your site is also adding the description meta tag ( please see the screenshot in the Sensitive Data Section ). Please check and remove the description added by your theme or plugin, that should fix the issue.

    Hope that helps. Thank you.

    You were showing something which I dont know,

    I told you earlier, I am not a programmer nor am I a coder.

    I dont know where and how to remove what you mentioned.

    I can see here the issue still exist.

    Why did you check different page?

    https://screencast-o-matic.com/watch/cqeF6V0pWx

    Watch above, It should play fine on chrome

    i am still waiting for your reply

    Hello,

    You had this code in your theme’s header.php file that was causing this issue:

            <meta name="description" content="<?php
    
            if (is_single()) {
    
                single_post_title('', true);
    
            } else {
    
                bloginfo('name');
    
                echo " - ";
    
                bloginfo('description');
    
            }
    
            ?>" />

    I have removed it and everything should work fine now.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    I will check later. Thanks.

    Of course I need more of your assistance.

    There are issues coming up since I am also in touch with the page builder side.
    I see that RankMath might have bug. It might have problem reading or retrieving data correctly.

    Yes, I say might. Server people gave the similar opinion too.

    • This reply was modified 3 months, 1 week ago by  Azizan. Reason: more info

    Hi,

    It might have problem reading or retrieving data correctly.

    Could you please explain what issue? Is some content not being analyzed or do you mean something else?

    Hi,

    I am currently in my hometown visiting my mother for a few days.

    Could you please log into my website, go to SEO analysis and focus on SE0 description, Keyword in Tile and Description, Site Tagline, Search Preview.

    In this website, description is read wrongly. I have actually installed RankMath in a few websites. Hence I can see difference. I might be wrong.

    You can also check website tagline and homepage meta description.

    I like this plugin, this is the plugin that I search for. I even ask plugin developer to develop this type of plugin, and they ignored my suggestion.

    Hope you guys make it better.

    Hello,

    I don’t see any issue with the Description and Focus Keyword missing in the title test. It is working fine on your site. I see the Site Title & Tagline is missing, which you can add by navigating to Dashboard >> General Settings >> Site Title/Tagline.

    Please see the screencast I added in the Sensitive Data Section.

    Hope that helps. Thank you.

Viewing 15 replies - 1 through 15 (of 18 total)

You must be logged in to reply to this ticket.