Links not indexed via Sitemap and images issue

  • Hello,

    I use RankMath months ago and i had a problem with submiting the sitemap to google, after few tests i was able to submited, but google still index links randomly not via the sitemap, Another issue that i’m facing actually is: When i search something related to my website exp “Apple PNG” the image showing on google is different from the original one in the website, Another example you search “Apple PNG” on google the original image shows perfectly, but when you click it takes to the main page on the website, I’ve been trying and don’t know how to fix this it happen on many links and images.

Viewing 1 replies (of 1 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    1). Have you been able to check for indexing errors on your search console dashboard?
    2). This suggests that the image thumbnails on your post are getting indexed. You will need to create an attachment sitemap if you want to index all the image content. You can achieve this by heading over to Rank Math > Sitemap settings > Media > Include in Sitemap
    3). This may happen when you have enabled the option redirect attachments to the posts that they appear which on this case might be the homepage. You can check if this is the case heading over to Rank Math > General Settings > Links > Redirect Attachments

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 1 replies (of 1 total)

The ticket ‘Links not indexed via Sitemap and images issue’ is closed to new replies.