Keyword and snippet not saving

  • Per the title and description, I entered a keyword and a description in the snippet of my WordPress post. When I click save draft/update and return to the ‘All posts’ page, in the Rank Math column, it tells me to update my post and the keyword is “not set”. I return to the post and the keyword and description are gone. The same problem shows up when I create a new draft and I’m not taking chances with the posts I’ve already published. Please see https://www.ramblingfeet.net/best-craft-breweries-in-cape-town/.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    Are you using the latest plugin update, version 1.0.45?

    Assuming you are using the latest version of all the plugins and the themes (please update if not yet), it would seem like a conflict with one of the plugins or the theme you are using.

    To determine that, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Please let us know if you find the culprit else we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hi

    Even with everything deactivated and in the default theme, the problem persists. I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    After checking it, it seems you get the following errors when trying to save:

    api-fetch.min.js:2 POST https://website.com/wp-json/rankmath/v1/updateMeta?_locale=user 403
    post.php:1 Uncaught (in promise) {code: "invalid_json", message: "The response is not a valid JSON response."}

    Those errors usually are caused when something is blocking access to the WordPress API REST.

    Since you already tried for plugin conflicts and even with everything disabled, it still doesn’t work, I would recommend contacting your hosting support, to check if something is blocking the WordPress API REST.

    Please let us know if you find the culprit.

    Looking forward to helping you.

    I checked with my hosting provider. According to them, neither the hosting nor the firewall are blocking access to the WordPress API REST.

    However, I tried pushing my production site to my staging site, and saving works as per normal on the latter. I will try pushing in the opposite direction to see if it sticks.

    Update: The keywords and snippets I was able to save in the staging site were ported over but I cannot save keywords or snippets for new draft posts.

    Hello,

    It appears locale=user related json string is already blocked on your site even with all plugins deactivated including Rank math and using theme 2020, please check the screenshot I have attached in the sensitive section. The string/query that is being blocked is the same query string that is later used by Rank math uses to update meta.

    Please show this to you host to help you.

    P.S. The screenshot was taken under troubleshooting mode. The error appears by just loading the edit page.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi, thanks for the update. I’ll check with the host and also ith the theme people just to be sure.

    Hello,

    Perfect, just let us know the result of talking with them so we can know if you need our help.

    Looking forward to help you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

The ticket ‘Keyword and snippet not saving’ is closed to new replies.