JSON Error

#199278
  • Hi there,

    I have recently migrated to RankMath from Yoast SEO, however, when trying to update the meta description of a post or page, the changes do not save. An error pops up, “Updating failed. The response is not a valid JSON response.”.

    This error seems to be consistent across all posts and pages.

    I have tried turning off the site’s firewall as well as deactivating the Litespeed Cache, neither worked as a solution. I also updated the PHP version of the server but still no change.

    I have also tried turning off the RankMath Analytics module, recreating the tables and rebuilding the index, all of which had no effect.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting Rank Math and bringing your concern to our attention. I’m sorry for any inconvenience this issue may have caused you.

    Since you have already check for any firewall for this issue, please also check if there can be plugin conflicts due to which you might not be able to save the metadata.
    You can solve these plugin conflicts by going through our Knowledge Base on Plugin Conflict.

    If the issue still persists, please also confirm if you have errors in the JSON that might be blocking the updateMeta rule like this one:

    yourdomain.com/wp-json/rankmath/v1/updateMeta?_locale=user

    If so, those errors usually are caused when something is blocking access to the WordPress REST API. I would recommend getting in touch with your web host to check if something is blocking the WordPress API REST. You should also ask them to check the Firewall Settings and whitelist the updateMeta rule.

    Here’s a link for more information about this issue:
    https://rankmath.com/kb/meta-data-not-saving/

    I hope that helps.

    Thank you, and looking forward to your update.

    Hi, thanks for the reply.

    I have disabled each plugin one-by-one. I have also installed the health check troubleshooting plugin and used that to emulate a clean WordPress install with default theme and no plugins and the issue persists.

    The error you mention is visible in the debug console and the following file displays a 403 error.

    yourdomain.com/wp-json/rankmath/v1/updateMeta?_locale=user

    I have tried whitelisting that URL in Cloudflare and in Wordfence with no luck. Oddly, some ‘posts’ seem to have no issue, but all ‘pages’ do.

    I will try to contact our hosting provider, in the meantime, do you have any other ideas?

    Many thanks

    Hello,

    Thank you for the follow-up.

    403 error means permission denied, so I would suggest checking with your web host for any firewall or security feature that might be blocking our API.

    Let us know how this goes after contacting your web host for this issue.

    Looking forward to helping you.

    Thank you.

    Hey, so I have faced exactly same problem with WPengine hosting. I contact the host and it appeared that this json script was blocked by GES security tool on WPengine and they said they need to whitelist it on their end. So, maybe you should ask your hosting support about it. Hope this will help. Cheers!

    Hello,

    @Serhii Thank you for sharing that information in this forum.

    If you have any other concerns, please don’t hesitate to contact us anytime by creating a new ticket to assist you further with anything else.

    Looking forward to helping you.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this ticket.