Job posting error missing organization

  • Hi, I started using Rankmath few weeks ago and i”m using job posting rich snippet. Current i have 5 job posts already published on my site. This morning i got these errors in my Google search console.

    ○Missing field “hiringOrganization” Missing field “title” Missing field “jobLocation” Missing field “description” Missing field “datePosted” Missing field “jobLocation.address”

    ○Please what will i do to correct all these errors..

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    It means you should fill all the fields in the schema, like I show you in the following screencast:
    https://i.rankmath.com/ot2ju0

    If after doing it you keep having errors, let us know and we will continue helping you.

    Thank you.

    No sir , I am not created any schema it will be automatic generated,but during installation i have on the setting of schema,so can’t find the error. It shows 2 error and 5 warning message when url crawl on Google bsearch console.

    If i am editing all post schema then any chance to remove the error.
    If you have any other information for me so plz help me to solve the issue.

    Hello,

    Thank you for contacting Rank Math today.

    Some of the schema fields will not be filled automatically since they are unique for each JOB posting. Please fill all the fields as illustrated by my colleague earlier on all your posts to fix this.

    You can always use the following tool to test whether the data for each post has been entered correctly: https://search.google.com/structured-data/testing-tool/u/0/

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)

The ticket ‘Job posting error missing organization’ is closed to new replies.