Issues with Leadpages and Categories

  • Hello !

    My sitemaps seems not available
    with leadpages : https://moncoachdenatation.fr/leadpages_post-sitemap.xml
    with category : https://moncoachdenatation.fr/category-sitemap.xml

    For leadpages, the support told me this :
    “You will need to use a third party plugin to have your landing pages included in your WordPress sitemap. Most commonly we see folks use the Yoast plugin for this purpose.

    That being said, typically, a user will have to add leadpages_post_type to the plugin’s configuration to tell it to include Leadpages landing pages in the sitemap it generates. There are several different plugins you could use for this, so this process can vary a little depending on which specific one is in use.

    Note: Instead of being leadpages_post-sitemap.xml, it needs to be set up as leadpages_post_type-sitemap.xml”

    Can you provide me some help please ?
    My SEO is a bit suffering with RankMath but i believed hard in this project who’s super user friendly

    Keep going !
    Thomas

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you please do the following:

    1. Head over to WordPress Dashboard > Settings > Permalinks

    Hit the save button once.

    2. Go to WordPress Dashboard > Rank Math > Sitemap Settings

    Hit the save button once.

    That should fix the issue.

    If it doesn’t, please do let us know so we can look at this further.

    Hello

    I’ve followed your instructions and it doesn’t solve the issue.

    Thomas

    Hello,

    Thanks for getting back to us.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    All the categories on your site are set to noindex, that’s why they are not appearing in the category-sitemap.xml sitemap.

    As far as, the landing pages sitemap is concerned, the sitemap URL is correct, it is and it should be post_type-sitemap.xml where post_type is the name of the post_type. I see the Landing pages sitemap is not showing any pages but I couldn’t figure out why. Also, the robots meta tag is missing on the Landing pages. Can you share your site’s FTP access so we could check and fix this issue on your site?

    Looking forward to helping you. Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Sorry for not following up quickly and any inconvenience that might have been caused due to that. The FTP access you added is not working for me, I am getting 408 Internal Error. Can you please check that?

    Looking forward to helping you. Thank you.

    Hello

    Sounds weird to me because i’ve just tested and it wor properly
    we’ve facing some issues with the website yesterday, maybe it will be ok this time.

    Can you please try again ?

    Thomas

    Hello,

    Sorry for not following up quickly and any inconvenience that might have been caused due to that.

    We tried to debug this issue on your setup but we couldn’t find the source of the problem. All the Leadpages on your site are set to noindex. The robots data doesn’t change no matter what we change in the backend. To me it looks like something in the LeadPages plugin is broken, as it’s not working with the other SEO plugin too and also the layout of the LeadPages is broken in the backed. Please contact the plugin author and show them this issue, maybe they could assist you with this issue.

    I hope that helps. Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)

The ticket ‘Issues with Leadpages and Categories’ is closed to new replies.