Issue with indexing of custom taxanomies

  • Resolved Nitesh

    Hi SUpport,

    this is regarding the issue that I have shared in the RankMath facebook group as well.

    I have already shared the login credentials above. Kindly check it.

    Here are my settings for the robots.txt – https://pastebin.com/bnTNe9si

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello,

    Thank you for contacting Rank Math today.

    The Noindex empty categories option is enabled on your site and /categories, /platforms don’t have any posts. If you want to index those pages, please navigate to Dashboard >> Rank Math >> Titles & Meta >> Global Meta and disable the Noindex Empty Category and Tag Archives

    Hope that helps. Thank you.

    Hello Pratik,

    Oh! This may be a reason but let me explain how I thought it should work…

    These are parent categories which have multiple other sub-categories and a lot of posts associated with those sub-categories. So, practially if you open that parent category acrhive page, you will find all the posts shown there from all their subcategories… and hence logically these category shouldn’t be considered ’empty’

    But technically, since I haven’t associated any of posts directly to that parent category, it is considering it as empty… but who actually does that practically?

    I mean, if I run a digital review site and there is category called “Phone” and there are sub-categories like “iphone”, “Android”, “Windows” of the category “phone”

    Now, if I write a new review on iPhone X, I am going to select the subcategory “iPhone” only. Right? …not the category ‘Phone” as well…

    But based on current setting, the parent category ‘phone’ will be considered as “empty” and hence my indexing setting won’t work.

    In short, the “Noindex Empty Category and Tag Archives” option should consider a parent category ‘non-empty” if the subcategories already have multiple posts.. this is how any SEO plugin works…

    Let me know if you still didn’t get it or not agree to this… and I am looking forward to a related update to this.

    Thank you.

    PS: I have also replied the same in the Facebook group as well to your response.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)

The ticket ‘Issue with indexing of custom taxanomies’ is closed to new replies.