Issue with homepage meta description and thumbnail

#276829
  • I’m having an issue with the meta description and thumbnail of my homepage.

    To be clear, I have already set the description and thumbnail of the homepage via the RankMath settings.

    Now, when I try to share my homepage on Whatsapp, the meta description and the thumbnail are displayed correctly. However, when I share the same homepage on the Facebook app or desktop, either the meta description doesn’t appear or the image doesn’t appear.

    I have attached screenshots of Whatsapp, Facebook desktop and Facebook app for your perusal.

    How can I fix this issue?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hello,

    Thanks for contacting us and sorry for any inconvenience that might have been caused due to that.

    I was able to check that you have duplicate og tags on your page and Facebook is fetching the description from the second tag:

    Please follow this troubleshooting guide to figure out which plugin or theme is adding the tag: https://rankmath.com/kb/check-plugin-conflicts/

    Let us know how that goes. Looking forward to helping you.

    I did the checkup as suggested and the thumbnail issue got rectified automatically. However, the meta description of the home page still shows the tagline of my blog instead of the actual meta description.

    Screenshot

    There is no change in the meta description even after activating all the plugins and the theme.

    Why is this happening and how can I change my meta description from the tagline to the original meta description?

    * even after deactivating all the plugins and the theme.

    Hello,

    The additional og: tags are still present in the page source.
    og

    After deactivating the conflicting plugin/theme, clear the cache and check the URL with Facebook Sharing Debugger.

    Click on the Scrape Again button to scrape the updated page.

    That should fix the issue.

    Looking forward to helping you.

    Hi Anas,

    I used the Facebook Sharing Debugger tool just like you said and also cleared the cache multiple times. However, it doesn’t solve the issue. As I mentioned in my previous post, my meta description is not being displayed even after deactivating all the plugins and activating RankMath using Health Check. It shows the tagline instead.

    So there is no scope of plugin/theme conflict at all.

    How can I debug this issue? I want to launch my website but this issue is bugging me endlessly.

    Hello,

    The duplicate OG tags are still present on your website. Please note that while debugging with the Health Check & Troubleshooting plugin, the live website is not affected for visitors or other websites (like Facebook’s Debugger). So upon testing with the debugger, you’ll see the same results.

    However, if you’re not sure, we can check this for you. We might need to take a closer look at the issue. Please edit the first post on this ticket and include your WordPress & FTP logins in the designated Sensitive Data section.

    Please do take a complete backup of your website before sharing the information with us.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Also, to be clear, I’m facing a couple of issues on my homepage (when shared on Facebook):
    1. My meta description shows the tagline instead of the actual meta description.
    2. My thumbnail shows the logo instead of the actual thumbnail.

    Please note that I have updated both the meta description and the thumbnail on RankMath yet I’m facing these issues.

    Hello,

    I checked and figured out that the second set of og meta tags is being added by your theme Ashe Pro. I checked and wasn’t able to figure out an option to disable the open graph tags. Please contact your theme’s support as they will be able to disable the og meta tags added by your theme.

    Let us know how that goes. Looking forward to your update.

    Thanks.

    Thank you! I will let you know if there is any issue after that.

    Hello,

    Please do let us know how that goes.

    In the meantime, please don’t hesitate to contact us anytime if you need our assistance with anything else.

    Hi,

    This is the reply I got from my theme’s developers. Kindly help.

    Hello,

    We are an SEO plugin so it’s obvious that we are going to generate OpenGraph meta tags on the websites to help with SEO optimization.

    Most themes that include those also offer the option to disable them when people install an SEO plugin because of this same reason.

    If they are going to release an update about this soon, as they indicated they will, the issue should get solved when that update is released.

    Don’t hesitate to get in touch if you have any other questions.

    Yes. I also told them that RankMath is taking care of the meta descriptions so I wanted to disable any duplicate OG tags from the theme. But they’re taking too long to respond.

    Do you know how to disable these duplicate OGs from the theme?

    Hello,

    Since there doesn’t seem to be an option present, your theme developers would be able to disable the OG tags generated by them.

    You can wait for their update and see if that fixes the issue.

    Hope that helps.

    Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 14 replies - 1 through 14 (of 14 total)

The ticket ‘Issue with homepage meta description and thumbnail’ is closed to new replies.