Issue with Elementor

  • Hi, there must be a problem with Rank Math and Elementor. I prepared a new post with Elementor and Rank Math, but it loads only when Rank Math or Elementor are disabled.

    Any idea how to solve this? Actually I disabled Elementor. I rolled back Elementor to ver. 2.6.8 but the problem persists.

    Post with the problem The post is in 3 languages and all 3 languages don’t load when Rank Math + Elementor are active.

    I get a timeout message or 500 – Internal Server Error

    • This topic was modified 3 weeks ago by  Be Ge.
Viewing 15 replies - 1 through 15 (of 25 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    This error is related to your hosting and could be stemming from the exhaustion of a certain server limit. Can you please enable DEBUG_MODE and WP_DEBUG_LOG which will allow errors to be logged into the file
    ‘/wp-content/debug.log’

    Here is some code to add to your wp-config.php file which will enable these constants:
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);
    define(‘WP_DEBUG_LOG’, true );

    Reload the page once again and let us know what kind of errors are reported so that we can help further.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hi,
    I have added the code to the wp-config.
    I have activated Elementor, flushed the cache an reproduced the problem with timeout on the post, but no debug.log file was created in wp-content.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    I have checked with my provider and he created the debug.log file. Anyhow, I reproduced the problem and nothing is written in the debug.log
    Please observe that the problem is only with the post created with Elementor with Rank Math active. All other pages / posts (created with or without Elementor and with Yoast) are not affected. It seems therefore not very probable that it is a server problem but it looks to me like a loop in some script. When Elementor or Rank Math are disabled, the post is loaded fast.
    I like your plugin and I will give you all possible support to solve the problem. But on the other side, I want to continue to use Elementor in the future. I hope therefore in a fast solution.

    I found a difference between the real permalink of the page and the permalink registered in Rank Math. The permalinks are different for each language but Rank Math registers the permalink only once for all languages (registered manually).

    The posts are
    German https://www.tourist-in-rom.com/de/gepaeckaufbewahrung-rom/
    English https://www.tourist-in-rom.com/en/luggage-storage-rome/
    Italian https://www.tourist-in-rom.com/it/deposito-bagagli-roma/

    but in the edit snippet section of Rank Math I see the same permalink for all 3 posts eg luggage-storage-rome. I can manually change it but then the permalink is changed in Rank Math for all 3 languages and in WordPress the permalink remains as above.

    Hello,

    Thank you for contacting Rank Math today and apologies for the delay.

    Could you please generate a new access token so that we can check this problem further?

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,
    I investigated further and found, that the plugin LuckyWP Table of contents is blocking the post. This is strange, because I have it on another page and there it is working.
    I have created a test post for you. On the internet, the post https://www.tourist-in-rom.com/en/test-luggage/ goes in timeout. But, as I reported, the post loads, when RankMath is disabled.

    About the issue with the permalink, please refer to the links in my earlier reply.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi there,

    Thanks for getting back to us.

    The affected post works as expected when Rank Math is activated. I have also gone ahead and created a test post on this link: https://www.tourist-in-rom.com/de/rank-math-support-test-post/ and also added a table of contents but this one works when both Elementor and Rank Math are activated.
    I can suggest that you reach out to the guys from Elementor about this and check if they have come across this before.

    Let us know how this goes. Thank you.

    Hello,
    I will ask Elementor about this.
    What about the wrong permalink registered in RankMath?
    I see pages/posts affected which were saved once with RankMath.
    Here is another one:
    https://www.tourist-in-rom.com/en/colosseum/
    https://www.tourist-in-rom.com/de/kolosseum/
    https://www.tourist-in-rom.com/it/colosseo/
    In the snippet editor for all 3 languages is shown the German permalink “kolosseum” and below is written
    “this is what will appear in the first line when this post shows up in the search results.”
    If I change it manually, eg. on the english page to Colosseum, this changes the permalink in the snippet editor in all 3 languages.
    I confess, this makes me really nervous.

    • This reply was modified 2 weeks, 5 days ago by  Be Ge.

    Hello,

    Thanks for getting back to us.

    Rank Math adds the hreflang tag to all the multilingual links and thus the change in permalink is normal since search engines expect this behavior.

    I hope this info helps. Thank you.

    So you say, this is normal? What has this do to with the hreflang tag? How can it be, that there are two different permalinks shown in one post (one of wordpress and one from RankMath)? I thought, WordPress itself does not accept identic permalinks even if in different languages.
    Screenshot

    Hi there,

    Thanks for the follow up.

    This is normal, the permalink created by Rank Math will only be used on the SERP result and will link to the post link created by WP on your site.
    If you have multilingual versions of the post then the the link created by RM will have different variations for each language.

    I hope this info helps. Thank you.

    Hi Michael,
    In fact I expected that RM will have different variations for each language. But in my case, the link created by RM is the same for all languages and it if I edit one, it changes the link in all 3 languages.
    Screenshot
    See post https://www.tourist-in-rom.com/en/luggage-storage-rome/

    Hello,

    I have raised this problem with our dev team and we will be getting back to you in a short while to discuss this further.

    We appreciate your patience. Thank you.

Viewing 15 replies - 1 through 15 (of 25 total)

The ticket ‘Issue with Elementor’ is closed to new replies.