Homepage / Mainpage not indexed and no permalink update

  • Hello,

    I have started with a small business website and I have exported the configuration from other (famous) seo plugin into Rank Math. It was working properly so far, but two issues occured:

    1. The hompage / mainpage of my domain will not be integrated into the sitemap. There were three pages before I have started with Rank Math, after changing there were only two pages remaining – main page ist missing now. For SEO I have to fix this asap. How this is working?

    2.
    Rank Math will put the text of the titleform of a page automatically into the text of the permalink. How can I deactivate that, so that permalinks will be shown as origin?
    For example: rankmath.com/privacy-policy >>> rankmath.com/rankmath-new-privacy-policy/privacy-policy

    3.
    I am using wp-rocket for caching. So I want to use the new option for sitemap-based caching. Are there any problems known when using this option with Rank Math? Actualy it is deactivated in my config.

    Thanks in advance for help and feedback.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    1. Could you please head over to your homepage and ensure you have not set it to noindex. If it is not set so, please share with us the URL of you site so we can test this from our end.
    2. The URL structure is determined by your settings in WordPress Dashboard > Settings > Permalinks. If your sthe structure you have set is not reflecting in your URLs please let us know so we can look into it.
    3. It is recomended to exclude sitemap URLs from caching. It usually results to 404s on your sitemaps.

    Hope that helps. If you have any further question(s), please let us know. Thank you.

    OK Michael,

    so my homepage is not set to noindex, never in WP settings nore in Rank Math. With my former installation (and seo plugin) is was working properly. I also had never problems with caching of sitemap, i never had excluded it form caching.

    I have set the permalink structure in WP settings again (save settings without changes), but this had no effect at all.

    Maybe you should have a closer look at this. How shall we go on now?

    Kind regards.

    Hello,

    Yes, I think we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    It looks like everything related to sitemaps was disabled.

    We made some changes and now the sitemaps are working fine.

    Could you please check?

    Hello,

    some other thigs I have found out: There must be an bug or error caused when using the google chrome browser. I have checked tis by using firefox, and in this case I have got an other layout of the window which is showing sitemap content in correct html code and it is showing permalinks of webpages correctly. Maye it would make sense to investigte in this.

    The overview graph of “position” in search console area of rank math is not shown correctly any more. Data error or anything else.

    I see also many entries in area of “404-errors”. Where does these come from and how can I avoid / clean up this.

    It would be nice if you could check this again for fixing.

    Thanks.

    Hello,

    It seems your page sitemap is not accessing the required styling. Please perform the steps outlined on this page to check for possible conflicts: Check for conflicts
    Most of the 404s seem to be related to theme.css. Please note we can only tell you about the 404s. We don’t know where they are coming from. You have to check that yourself.

    Here’s how to fix the 404s with Rank Math.
    https://rankmath.com/kb/fix-404-errors/

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.
    ​​​​​​

    Hi,

    so I have tested my installation with health check plugin.

    Starting with all plugins deactivated (incl. astra theme), I have activated RankMath only. So already in this basic configuration the errors will occur. I think in conclusion of this, my installation is unlikely not root cause of these errors.

    Concerning sitemap problems I have read many posts of customers in faq section. Maybe there is an issue for development… At the moment it semms, that sitemap option is workin correctly (all pages were shown correctly in sitemap and processed by google).

    Other feedback or ideas?

    Regards

    Hello,

    Thank you for the follow up.

    Allow me to consult on why your page sitemap seems to be missing the styling and get bac to you. Please don’t remove the access yet.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    so I do not remove your access for your further investigations. I hope you can find somthing out what helps to fix the problem(s).

    Thanks.

    Hello,

    The page-sitemap on your site is not added by the Rank Math plugin. Even after disabling the Sitemap module, the page-sitemap is showing the XML code. To me, it looks like there is a file in your root directory page-sitemap.xml which is loading instead of the Rank Math sitemap. Can you please confirm that?

    Looking forward to helping you.

    Hello,

    I had installed an additional plugin to create a physical sitemap file for testing the problem by myself. This is not active any more, I have deinstalled it. But I forgot to remove the xml-file (page-sitemap.xml), so it is still remaining at root directory.

    If you want you can rename it for your further investigations. But please keep it as backup, do not delete it.

    Thanks.

    Hello,

    I removed the user-added canonical in the meta box advanced settings of your home page and that resolved your issue. Please check this and let us know.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    so this is working so far. Now the correct styling is shown and this issue is fixed. Thanks. But I did not find the area where I can change this setting in WP. Is this a general setting or individual for each page? Can you please describe it again?

    An other question more:
    What is the effect when a page is markesd as “pillar content” and for which kind of pages does it make sense to mark up? (e.g. start page,…)?

    Thanks and regards.

    Hello,

    You can find the option to change/edit canonical URL on the Rank math metabox advanced tab.

    Pillar contents are usually posts or pages that relate to what your site is about, having a touch of every other post in its content. Here is an article to help you:https://blog.hubspot.com/marketing/what-is-a-pillar-page

    Looking forward to helping you. Thank you.

    ​​​​​​

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this ticket.