Homepage AMP shows as 'follw,noindex' after enabling RankMath SEO

  • So my site (https://www.techvise.pk) is showing the following problems when using RankMath:

    1. Rel next link is listed as follow,noindex (i’ve checked my settings already)
    2. og:title is showing as ‘Page not found…’ which is crazy…. Single pages dont have this problem.

    Sample source code..
    <html amp lang="en-GB"> <head> <meta charset="utf-8"> <link rel="dns-prefetch" href="https://cdn.ampproject.org"> <meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1,maximum-scale=1,user-scalable=no"> <link rel="canonical" href="https://www.techvise.pk/"> <link rel="next" href="https://www.techvise.pk/amp/page/2/" /><meta name="robots" content="follow,noindex"/> <meta property="og:locale" content="en_GB"> <meta property="og:type" content="website"> <meta property="og:title" content="Page Not Found | TechVise Pakistan">

    I’m using AMPforWP plugin. The plugin is updated, RankMath is selected in SEO and enabled to work with AMP.
    I’m also using Weglot translation plugin that doesnt work RankMath Sitemaps, so sitemap functionality is delivered via XML Sitemaps.

    If you try to run diagnostics via AMP validator, it wont work because i’ve moved all these shenenigans to a dev site which is blocked by robots.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Can you confirm that you have enabled the Rank Math AMP module? If so, does this issue replicate when you deactivate this module?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    I have disabled the RankMath AMP module and I think its sort of working now.

    1. ‘nofollow,index’ is still there
    2. ‘Page not found’ has disappeared but i still dont see any description

    Since im no expert, i can only compare this to the source generated by Yoast SEO plugin that is currently running on the live site. https://www.techvise.pk/amp/

    Can you double check this and confirm?

    • This reply was modified 2 months, 2 weeks ago by  Quratulain Habib. Reason: longer explanation
    • This reply was modified 2 months, 2 weeks ago by  Quratulain Habib.

    Hi there,

    Thanks for the follow up.

    I think you forgot to share the URL to the dev site so that I can make a comparison.
    Instead, would you mind sharing some access to the dev site so that we can review the settings? Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    HI there,

    Thanks for the access.

    The noindex option is arising from the fact that you have set the whole dev environment to noindex via the Admin > Settings > Reading.

    I have gone ahead and installed a different amp plugin ie AMP for testing and this works smoothly with all the meta data displayed. Please activate it and test this out.

    Let us know how this goes. Thank you.

    Hi, This is great, thanks.

    I think whatever the last update did, worked. Since i tried out these settings on the live site too.

    Right now, the whole setup is working. Unforuntately, i’ve recently started using some FAQ / How to snippets into my articles. RankMath doesnt provide that so i will need to work with Yoast SEO for the time being.

    I hope you guys release that very soon.

    Hi there,

    Thanks for the follow up.

    Hopefully this feature will be available sometime soon 🙂

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

The ticket ‘Homepage AMP shows as 'follw,noindex' after enabling RankMath SEO’ is closed to new replies.