Google not refreshing the post-sitemap.xml

#96062
  • Resolved Acapturer
    free

    Hi There,

    I have posted a new post to my site two weeks ago and still not being found from Google. After further investigation, I find that is because Google has not refreshed all sitemaps.
    sitemap_index.xml is refresh daily. However, the post-sitemap.xml have not been refreshed since OCT 07.

    Could you please share me some light on which things have gone wrong? Thanks!

    Following is my Google Search Console as at now.

      /sitemap_index.xml

    Last read
    10/23/20
    Total discovered URLs
    355

    Sitemap index processed successfully

    Sitemaps read
    Sitemap | Last read | Status | Discovered URLs
    /category-sitemap.xml | Oct 22, 2020 | Success | 11
    /page-sitemap.xml | Oct 15, 2020 | Success | 14
    /post-sitemap.xml | Oct 7, 2020 | Success | 99
    /post_tag-sitemap.xml | Oct 7, 2020 | Success | 230
    /wpdmpro-sitemap.xml | Oct 16, 2020 | Success | 1

    Thanks in advance!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Just as further information, the new post was published on the 2020/10/15 at 11:19 pm.
    And until today, it is still unknown to Google.

    Hello,

    Thank you for getting in touch with us.

    Is your post being shown in your post sitemap? Please check this by going domain(.)com/page-sitemap.xml

    If the sitemap is working fine, you can try validating it on this link: https://www.xml-sitemaps.com/validate-xml-sitemap.html

    If the validation works, please move to the second point.

    Have you verified the correct version of your website on Google? Please check if you have verified the www (or non-www) and https (or http) version of your website. If there is a mismatch, please fix that.

    If all this is done please do the following:

    1. Flush the Sitemap cache by following this video screencast:
    https://i.rankmath.com/pipRDp

    2. Exclude the Sitemap files of the Rank Math plugin in your caching plugin. The cache could be via a plugin or from the server. For plugins or Cloudflare, please follow this article:
    https://rankmath.com/kb/exclude-sitemaps-from-caching/

    3. Head to your GSC, remove and resubmit your main sitemap file(sitemap_index.xml)

    That should fix the issue. Please let me know if that does not. We are here to assist.

    Thank! I have recsumbitted the sitemap and let’s wait and see.

    BTW, I have also done a URL inspection to that particular post. I am not sure if it is related.

    Following is the response from Google:

    URL can be indexed
    Crawl
    Time: Oct 28, 2020, 10:03:57 PM
    Crawled as: Googlebot smartphone
    Crawl allowed? Yes
    Page fetch : Successful
    Indexing allowed? :Yes
    AMP version details : AMP Page is valid with warning
    Issues: Error in required Structured data element.

    Following is Robot setting for the page:
    Robots Meta: Index

    Hello,

    Could you share the URL so we can check it (in the Sensitive Data section)?

    Looking forward to help you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi There,

    I have added the page via sensitive data.

    BTW, a few things:

    1) After resubmitted the sitemap, Google has finally refreshed the sitemap and found the page.
    2) However, Google also advised the page can be indexed but is still yet to index and
    3. Error in required structured data element for AMP pages. (It is one of the 54 pages with the same problem)

    Hello,

    About the message you got from Google, those are good news. True, it hasn’t be indexed yet but Google found it and it will index it. Could you check it in a few days and let us know if it is already indexed?

    About the Schema issue, it seems it is due to you need to set a logo in your blog (inside Rank Math). I have recorded a screencast showing you how to do it: https://i.rankmath.com/iiUtLj

    Looking forward to help you.

    Hi Alberto,

    Apologise for my delay and thanks for your help. It is all good after followed your instruction!

    Thanks for your advise!

    Elim

    Hello,

    Those are good news! Then, do you have any other questions? Or do you want us to close this thread? In any case, we will be here if you have any other questions or issues in the future.

    Looking forward to help you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)

The ticket ‘Google not refreshing the post-sitemap.xml’ is closed to new replies.