Google Analytics Doesn’t Turn On

#133931
  • Resolved Josh
    free

    I’m trying to set up Google Analytics in General Settings. It shows my account and property etc. but when I save the page, the little grey dot doesn’t turn green (unlike Search Console). I did not turn on the “install analytics code” button because I have GTM installed on my site already. Is this why the Google Analytics section won’t turn green?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    Please follow these steps:

    A. Pre-check List

    1. You should not be using Google Analytics v4 or Matomo Analytics.

    2. Update to the latest version of Rank Math Free & PRO

    3. Ensure that you are logged in to your paid account:
    rank math member area

    4. Disconnect and reconnect your account from inside WordPress:
    reconnect rank math account

    B. Refresh Tokens

    1. Please delete RankMath’s app from here:

    https://myaccount.google.com/permissions

    remove rank math app

    2. Re-create tables by clicking WP Dashboard > Rank Math > Status & Tools > Database Tools and click the Re-create database Table button.
    re-create analytics tables

    3. Reconnect the account inside Rank Math by clicking here and ensure that you approve all the permission notices that shows up:
    WP Dashboard >> Rank Math >> General Settings >> Analytics tab, and click the Reconnect link
    reconnect analytics

    4. Let the process complete and it might take around 30 minutes.

    5. Now head over to WP Dashboard > Rank Math > Status & Tools > Database Tools and click the Rebuild Index for Analytics button.
    Rebuild Index for Analytics

    6. Please check if the data shows up here:
    /wp-admin/admin.php?page=rank-math-analytics#/
    analytics data

    If that does not help, please paste the data from here:
    WP Dashboard > Rank Math > Status & Tools > System Status and click the Copy System Info to Clipboard button
    system info

    We really look forward to helping you.

    Just to confirm: it only connects with the Pro accounts?

    Hello,

    You can follow the steps without the PRO.

    The steps provided are to help you with your issues or determine if its something else.

    I hope this resolves your issue.

    Hello,

    Sorry for the inconvenience.

    I wanted to add that if you are using Firefox, please try saving the changes in another browser.

    If that saves the settings, rest assured we are working on a solution for the issues on Firefox.

    Uzair,
    Thanks. It was entirely a Firefox issue. Tried Chrome. Success! Analytics now connected!

    It was the Firefox issue. Thanks!

    Hello,

    Glad that helped.

    Please feel free to reach out to us again in case you need any other assistance.

    We are here to help.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

The ticket ‘Google Analytics Doesn’t Turn On’ is closed to new replies.