Focus Keyword not found in URL

  • When typing in a custom URL, RM fails to see my keywords inside. For instance, a sample URL would be

    https://interstate411.us/arkansas-highway-9-perryville-to-oppelo where “Perryville to Oppelo” is the Focus KW.

    Under the Basic SEO section, the line ‘Focus Keyword not found in the URL” is shown with the red X, even though the keyword is in the URL.

    (May be easier to explain with screenshots, below)

    1. Title of new / edited post
    2. What RankMath does
    3. Correct URL on the front-end

    Please advise, thanks 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    Thanks a lot for your query and we are so sorry about the trouble this must have caused.

    Can you please click on the primary focus keyword so that the tests are running against that particular focus keyword:
    null

    If it doesn’t work, please let me know.

    That one is highlighted. Still nothing

    • This reply was modified 6 months, 4 weeks ago by Dietrich.

    Hello,

    Thanks for getting back to us.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Dietrich,

    It appears you had enabled the remove stop words options:
    null

    This option removes stop words like “to” from your URL and that is why it wasn’t working.

    I disabled that option and it is working fine now:
    null

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Thanks much!

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/?rate=5#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

The ticket ‘Focus Keyword not found in URL’ is closed to new replies.