Feature Image Thumbnail Issue

  • Hi There,

    After the recent update of rankmath plugin. My website is showing website logo as a Feature image Thumbnail instead of original feature image in SERPs in most of the posts. May be i have changed some settings but i’m unable to find it.

    Kindly help me out to figure it out. Where are the settings to show my original post feature images in SERPs.

    Thanks

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Please share with us your site URL so we can look into this issue.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello,

    Thank you for the follow up.

    I have tested your site on Google SDTT(https://search.google.com/structured-data/testing-tool/u/0/) and your site to be missing related schema. Please head over to Rank math > Titles & Meta > Local SEO and add your site data.

    Please note that sometimes Google can sometime ignore the site custom settings and choose to display data they find relevant to the search term.

    Hope this you. Thank you.

    ​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Micheal,

    Thanks for the reply and helping me. I followed what you told me kindly check the data i have shared with you. The problem is coming in the posts and feature thumbnail in the SERP.

    Thank you.

    Hello,

    I have checked and the image you have set to be displayed there is not found when trying to navigate to it, that is why Google doesn’t find it and shows another image. I have added the image URL that is not working in the Sensitive Data section, so you can check it.

    Looking forward to help you.

    Hi Alberto,

    Thank you so much. Got it, thanks a lot for your help.

    Hello,

    We glad we could help you.

    Please let us know if we can close this and mark it as resolved.

    Hope that helps. If you have any further question(s), please let us know. Thank you.

    Still, I am facing the same issue featured images not showing in SERP

    Hello,

    Thank you for the follow up.

    It appears google is not able to see the image you have set for your recipe. Please check the test results and screenshot attached in the sensitive section.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi There, Please share with me an email so i can send you a temporary login. Thanks
    Furthermore i have added the snapshot. Rankmath is showing 404 error on these files but these files are available in my server. I’m unable to figure out the issue.

    Hello,

    You can use support@rankmath.com to give us access to the website.

    Looking forward to help you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi There, I have updated the sensitive data kindly check it. Thanks

    Hello,

    It appears Google was using the Open graph image you have set in Titles & Meta > Global Meta. The image you have set seems to have been crawled a day ago, please check the screencast I have attached in the sensitive section.

    On your 404 monitor log, could you please check your robots file and .htaccess for related rewrite rules that might be causing the issue.

    Please note we can only tell you about the 404s. We don’t know where they are coming from. You have to check that yourself.

    Here’s how to fix the 404s with Rank Math.
    https://rankmath.com/kb/fix-404-errors/

    Looking forward to helping you. Thank you.

    ​​​​​​

Viewing 15 replies - 1 through 15 (of 17 total)

You must be logged in to reply to this ticket.