FAQ Schema not showing

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    We might need to take a closer look at the settings. Please include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:
    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):
    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    It looks like you have created the FAQ on some other page, added it to the reusable blocks, and have used the current FAQ Block as a reusable block.

    The FAQ Block needs to be added as an FAQ Block in order for Rank Math to detect the insertion and then add the necessary Schema to the page’s header.

    Please remove the reusable Block and add the FAQ Block afresh.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    No, I added Rankmath FAQ blocks to the Home page first, then converted the whole container to a reusable block after that.

    I tried to convert the reusable block to a normal block, it did not help.

    Next, I created a new section and added two Rankmath FAQ blocks for testing, but still there is no FAQ schema returned by the Google testing tool.

    Found a temporary workaround. Adding this code snippet to functions.php solved the issue:

    add_filter( ‘rank_math/schema/nested_blocks’, function( $nested ) {
    $nested[] = ‘generateblocks/container’;
    $nested[] = ‘generateblocks/grid’;
    return $nested;
    });

    So I did some more testing and found the issue:

    Rankmath does not create the right markup when the FAQ blocks are inside a GB container (https://generateblocks.com/).

    Please see this test page where I put FAQ #1-3 inside a container and FAQ #4-6 without:
    https://gp.coinpanda.tax/faq/

    Only FAQ #4-6 is showing in Google Rich result test.
    Would you be able to look into this and fix the compatibility issue? Generatepress/Generateblocks is a highly popular WP theme+plugin so I assume there are many other websites with the same issue?

    Looking forward to your reply.

    Hello williamc,

    Thank you for sharing the working code.

    Do you wish to mark this as resolved now?

    If you have any further question(s), please let us know. Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this ticket.