FAQ MainEntity Missing Problem

#133266
  • First, let me say I’m loving RankMath and I thank you for the product.

    I see on your forum that there are quite a few issues with Schema tests showing that the MainEntity is missing on RankMath’s FAQ schema. So, I’m not alone I guess.

    Anyway – I am getting this error on my website.
    1) I am using Blocks on my wordpress via Gutenberg
    2) The Questions were NOT hidden
    3) I tested several pages and all come up with the same error “MainEntity Missing” or “Unnamed Item”

    I did not find an answer on this issue in your forum and it seems you may need to go into the site to see what the problem may be so I’m providing a page for you to look at but if you need anything else – let me know.
    Thank you for your help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    I tried re-creating the FAQ block form my end and tested it and it was working.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress & FTP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    After doing some test from my end and comparing to your end, I notice that you added FAQ Schema from the Advanced Tab.

    And looking at your page, you are using FAQ Schema Block.

    Do you know that once you’ve added all the FAQs for the FAQ Schema, you can publish or preview your posts in WordPress, and the appropriate FAQ Schema code will be added to the post by Rank Math.

    Here’s the information from our KB:
    https://rankmath.com/kb/faq-schema-block/#previewing-the-faq-schema

    You can try removing the FAQ schema from Advanced Tab and do a code test after.

    I hope this resolves your issue.

    Danial,

    Thank you so much for looking into this but I’m not sure what you mean by “Advanced Tab.”

    I don’t use that or at least I’m not aware that I use it or have it on at all. If so – how do I turn it off?

    When I add an FAQ Block I simply click on the Plus sign either in the post or on the top left corner to add the RankMath FAQ block.

    I checked the Rank Math plugin and searched through the dashboard, the general settings, the schema templates and could not find an “Advanced Tab”.

    I went through the link to the video you sent but I didn’t see anything there that I don’t already do. Sorry.

    I’m still getting the MainEntity missing error on my pages that have the RankMath FAQ Schema.

    I’m sorry to be such a moron here – I’m sure you are very tired of answering these basic questions but I hope you can help.

    Thanks
    Esther Kane

    Hello,

    I believe what my colleague meant to say was the Schema tab of Rank math meta box. I checked and you had added empty FAQ schema, I have check the screencast I have added in the sensitive section.

    I removed the extra FAQ and that seems to have fixed the issue, I have added a screenshot of this too in the sensitive section.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Hi Michael,

    Thanks for your info. I did not see a screenshot that you mentioned but I think I know what you’re talking about.

    1) The Rank Math meta box on the right side of the screen has an option for “Schema Generator”
    2) So, what you are saying is that I should NOT use that.
    3) BUT – now the page that does not have that any longer does NOT show an FAQ Schema on it at all.

    What I mean is that I put the URL…
    https://seniorsafetyadvice.com/how-to-prevent-hypothermia-in-the-elderly/

    Into https://search.google.com/structured-data/testing-tool/u/0/

    And an FAQ Schema is NOT detected.

    Actually – that is why I initially went in and clicked on Schema Generator button and added an FAQ Schema.

    Okay, so I did an experiment – I went in to another page that has FAQ on it…

    https://seniorsafetyadvice.com/how-to-make-a-two-story-house-elderly-accessible/

    I went in and clicked on Schema Generator and this time I went through the whole thing and ADDED each question and answer.

    This now works – everything is valid.

    So, what I have not read anywhere on the forum or how to videos, etc. is that when we use RankMath’s FAQ Schema and add it as a block to our wordpress post – we have to ALSO click on the Schema Generator in the Rank Math Meta Box and REPEAT the questions and answers.

    Perhaps I missed that somewhere and I’m sorry.

    Rank Math is a really cool tool – but maybe you need some beginning bloggers to write your “how to” scripts and videos. We’re not all as smart as you guys are!

    Thanks again for the info and your help.
    This issue is resolved!

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

The ticket ‘FAQ MainEntity Missing Problem’ is closed to new replies.