Even after redirecting, ?m=1 is showing in the URL.

  • Hello Rankmath team…
    I have moved my website from Blogger to WordPress.I used to use another plugin for redirection earlier. But after that I installed your super plugin instead of Yoast SEO and redirect is also working with it. But the redirect of the home page is still not working.
    Source: https://waytoidea.in/?m=1
    Target URL: https://waytoidea.in/
    But it is still going to the old link, https://waytoidea.in/?m=1
    Please help…
    I am waiting your response!

    Thanks and love from Rajasthan India 🇮🇳

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Unfortunately, Rank Math is not able to redirect (yet, we are working on it) URLs with ‘?’ on it (called URL with parameters). That is why your redirection is not working.

    To fix it you can use a plugin that supports it, like this one: https://wordpress.org/plugins/redirection/

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Okay. I used this (refraction plugin) earlier also. Hopefully this problem will be fixed.

    Thanks
    Vishal Meena

    Hello Vishal,

    We are super happy that this helped you with your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)

The ticket ‘Even after redirecting, ?m=1 is showing in the URL.’ is closed to new replies.