Elementor Issue

  • Hello. I use elementor 2.5.1 and RankMath 1.0.18.
    The RankMath is not reading the content inside the pages, and gives a score of 47/100. If I create the text off elementor and save as a normal page of wordpress works fine, but on a page edited and saved with elementor my score is 47/100

    See printscreens please.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    Thank you for contacting MyThemeShop and sorry for any inconvenience that might have been caused due to that.

    Can you please edit your post and add your website’s login details in the Sensitive area http://i.mythemeshop.com/ZmJGxp by using this plugin?

    Temporary Login Without Password

    Looking forward to helping you. Thank you.

    Hello, thank you.
    Do I really need to give admin access even if temporary? I don`t like to give login/passwords to admin to website to stranger… even when administrators.

    There is no way to solve this?

    Hello,
    You don’t have to share your password with us, you can use this plugin: https://wordpress.org/plugins/temporary-login-without-password/
    It will give us access to your dashboard temporarily without your password.

    Looking forward to help you.

    I’m seeing this same thing with Elementor. Basically, if the content is created with Elementor, RankMath doesn’t seem to recognize/count it toward the SEO score.

    I’d be happy to give you admin access to our site if the OP won’t.

    hey @chris, that would be super. I am so sorry you are facing this issue to begin with.

    Please open a new ticket and include your logins in the sensitive data section so we can check.

    You can use this plugin to generate a temporary login link as well: https://wordpress.org/plugins/temporary-login-without-password/

    We really look forward to helping you.

    Just to ssay I am experiencing the same. For example, my homepage currently scores 55/100 via Rankmath, with comments such as…

    ‘Focus Keyword doesn’t appear at the beginning of your content’ – it does
    ‘Focus Keyword doesn’t appear in the content’ – it does
    ‘Focus Keyword not found in subheading(s) like H2, H3, H4, etc..’ – they are

    There are others and it is consistent across pages, so I would agree with the OP that there are issues with reading data from Elementor created pages.

    Perhaps something to reach out to the Elementor folks to discuss.

    Hello,

    Can you guys please open a separate support ticket for yourself, so the original poster is not notified for every message from this ticket?

    Looking forward to helping you. Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this ticket.