Duplicate field “FAQPage”

  • Hi Rankmath Support Team,
    I’m getting Duplicate field “FAQPage” error with many post in GSC. While I use “FAQ Schema” in only 4 or 5 post. Please help me to fix this issue.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you share some of the affected URLs in the Sensitive Data section so we can check them and provide you with a solution?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Thanks for your quick response.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Unfortunately the images embedded in your page blur out when zoomed and we are unable to make our the links. Please use https://imgbb.com/ to share your images/screenshots with us. I however tested the links under Some Post Link on Google SDTT and there are no issues related to FAQ Schema.

    You however seem to have an issue on Article schema which doesn’t appear to be generated by Rank math. Please note it is recommended to only have one Schema plugin on your site to avoid conflicts.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Thank you for contacting Rank Math today.

    I have tested your URLs and they don’t seem to have an issue with FAQ, please check the attached screenshots. You should also check what is generating the extra schema markup as it seems like you have schema from another plugin or your theme. To determine that, please follow this troubleshooting guide: https://rankmath.com/kb/check-plugin-conflicts/

    Looking forward to helping you. Thank you.

    Hi Rankmath Team,
    Thanks for your response. As you say, I re-checked my plugin list and I have found another schema markup plugin. Which is installed by default with the theme. But, now I have deleted that plugin and clear website cache and post cache from google and request re-indexing that post in Google Search Console.
    But, 3 days passed but the problem not resolved yet. Please tell me what should I do?

    • This reply was modified 3 days, 15 hours ago by Alok Kumar.

    Hello,

    Thank you for the follow up.

    Have you tested your page with Goole SDTT after deleting the plugin to see if the duplicate FAQ issue is appears there.? Could you also share the affected URL(s) so we can also test this from our end.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I have checked the URLs you have shared and the first seems to have only one schema, which I believe is as expected. The second URL only has a Blogposting schema, no FAQ schema. You can test this here: https://search.google.com/structured-data/testing-tool/u/0/?

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi, Thanks For Reply,
    Yes, You are absolutely right. I used “FAQ Schema” in only first, not in second link of the post. but, why my all post getting error in GSC with those blogpost FAQ Schema in which I’m using FAQ Schema.
    I mean, if I’m using FAQ Schema in the 1st blogpost, then it automatically added other post of the blog in which i’m not using any schema.

    Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this ticket.