Domain Properties don’t work

  • Hi,

    If you have a ‘Domain Property’ in Search Console it does not pull through into RankMatch Search Console. It shows a different site from GSC.

    When will there be support to add a ‘domain property’?

    Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi Tim,

    Thanks for getting in touch with us.

    We already support that and have supported that from Day-1.

    If your website is not appearing for some reason, please reauthorize the GSC.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    It does appear, but after selecting and authorizing it, it reverts to a different site completely. There is no validation even.

    This is specifically for ‘domain properties’, which are different to just single, specific URLs added to GSC.

    Please can you test your side?

    Hi,

    Here is a screenshot of the domain property in the GSC:

    Here it is showing the data without any issues:

    If it isn’t working for you for some reason, please add support@rankmath.com as an owner of the property and then share the WP logins in the sensitive data section so we can look into this.

    • This reply was modified 1 month, 2 weeks ago by Uzair. Reason: Edited screenshot

    It shows data but if you have multiple sites in GSC, it takes one that is not a ‘domain property’. Test it for yourself please. It should at least validate that the domain you’re putting it on is the same as the one you’re authorizing, but it can be completely different.

    Check the ‘search analytics’ tab to see if the keywords correlate with the site you’ve just added, please.

    Hello Tim,

    Could you please add support@rankmath.com as an owner of the property and then share the WP logins in the sensitive data section so we can look into this.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Please check it on your staging server. It will be the same. Thanks.

    Hi Tim,

    We have tested it on testing and live websites – we can’t replicate the issue you are describing.

    Could you please record a video using loom.com so I can share that with the dev. team?

    Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

The ticket ‘Domain Properties don’t work’ is closed to new replies.