Disabling product category schema is not working

  • Hi, i have disabled the option to show schema on product categories but the schema for the categories is still there. I did all what i found.
    I disabled all the plugins and themes, after that i enabled woocommerce and rank math only but the schema for the categories pages is still there, what can I do?
    I tried disabling all the plugins and after that I enabled only woocommerce and the schema is not there, after that I enabled Rank math and the schema appears again, so, It is rank math the problem.
    Thank you very much for your time.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    any news?

    Hello,

    I checked your site and you don’t seem to have enabled the option to remove schema from your product category pages. To do this you should head to Rank math > Titles & Meta > Product Categories and enable the option to remove snippet
    omg

    I enabled this option for you and checked one of your categories and with Google rich results test tool and the product schema

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    I understand, but the option was activated before i sent you the request, i think after the tests removing all the plugins, etc i let it activated. Now all is ok, thank you very much

    Hello,

    We are glad this was helpful.

    Do you wish to close this thread?

    If you have any further question(s), please let us know. Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this ticket.