Connect Google Services not working

  • When i try to add a google account to the setup wizard “Connect Google™ Services” I connect via my account but no links are showing to select …
    The website is added and validated by google search console and google analytics …
    This is what I see on “Connect Google™ Services” https://prnt.sc/vmbfoz can’t select anything… but the account is connected…
    Any suggestion on how to fix this issue? Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • same Problem, that I got today setting up the site for a Client!
    Would be great to have a solution to that!

    I dont think is it properly working….. having same issues

    Hi,

    I also have the exact same issue.

    Any solution?

    Same here not working if use cloudflare dns

    After try 3-5 times finally it working now

    Hello,

    Thank you for getting in touch with us.

    Please make sure that you have verified the correct version of your website on the Google Search Console (http or https, www or non-www).

    Then, please make sure that the Google account you used to connect your Google Search Console profile is the same one you have used to verify your domain on GSC.

    If it still doesn’t work, we have found that using a different Google account to verify your domain and connect your website usually works. Or, you can try using the Google Site Kit if it still won’t work and disable the Search Console inside Rank Math by going to WordPress Dashboard > Rank Math > Dashboard

    I hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this ticket.