Categories 404 When New One Created

  • Hey,

    I’m getting an intermittent issue where if I create a new product category, all of the categories 404.

    To fix it, I can go into General Settings >> Woocommerce and then save again and then they all start returning a 200 again.

    I imagine this is an issue with permalinks from having remove category base turned on.

    Thanks

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hi,

    Thanks for getting in touch with us.

    Is this a recurring issue or did you see this happen just once?

    If this keeps happening, we may need to take a closer look. Next time this happens, share your .htaccess file and then save the permalinks. Then share the .htaccess after you do that so we can check the difference and give you the next steps accordingly.

    We look forward to helping you.

    This is a recurring issue. I’ve just done that but there was no change to the .htaccess.

    I’ve added it into the sensitive data area so you can see what it looks like.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    We might need to take a closer look at the settings. Please include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:
    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):
    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Is it okay if I give access to a staging site?

    Hi Sam,

    If the same issue occurs on the staging site then sure, you can share the logins of the Staging site.

    While we are at it, would be great if you can share FTP details as well so we don’t need to go back and forth.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Sam,

    I created a series of new product categories and continuously checked the new and old product category URLs.

    I couldn’t find a 404 even once.

    Is there a particular set of steps we must follow to see the issue? If so, could you share that with us?

    I just managed to get all product categories to 404 by doing this:

    1) Head into the products post type and select a product
    2) Add a new product category using the menu in the right sidebar
    3) Before creating the category, set the ‘parent’ to ‘All CBD Products’
    4) Save the product, all product categories should now 404.

    Although I just tried doing this again, and it didn’t cause them to 404, frustrating because it doesn’t happen everytime.

    Hi Sam,

    Thanks for the patience.

    I have just tested this on your site and I was also able to replicate this on testing site.

    This has been submitted to our dev team for closer investigation and we will be getting back to you in a short while.

    We appreciate your continued patience. Thank you.

    Hi Sam,

    I am sorry but I don’t see the issue:
    https://i.rankmath.com/hsOSZn

    Am I following the steps correctly or did I miss a step?

    Hi both, sorry mixed messages between the two of you. Did you manage to replicate this? I think the issue is caused by the ‘Remove Category Base’ option in General Settings >> Woocommerce

    Hi Sam,

    If you check my screencast at around 0:13, you will notice that the option is already enabled.

    Maybe my colleague was able to replicate it only on your install. I will have a word with him and we will get back to you.

    Hello,

    It looks like some functionality in the Woomart theme is conflicting with Rank Math which is causing this problem. I have forwarded this issue to our Development team, they will further debug this and if possible release an update with the fix.

    Till then, please update the permalinks whenever you create a new Product Category or disable the Remove Product Category base option.

    I hope that helps. If you need any other assistance, please feel free to let us know. We are here to help.

    Thank you.

    Thank you for the update.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 16 total)

The ticket ‘Categories 404 When New One Created’ is closed to new replies.