Canonical URLs not working with wordpress multisite

#130003
Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello,

    Thank you for getting in touch and I am extremely sorry about the trouble this might have caused.

    By not working, do you mean it is not showing or it is showing wrongly ?

    Rank math adds canonical automatically to pages/posts if they are set to index. If it is not being added, then here are a few things you must check for in order to see why the posts aren’t getting indexed.

    1. Make sure the post is not selected as ‘noindex’ in WP > Posts > Your Post > Advanced Tab in Rank Math.
    Screenshot:

    Individual Post Advanced Tab

    2. Ensure that the noindex is not selected for Global or Posts meta:

    Noindex Settings

    If this doesn’t help, please share some URLs affected and some screenshots showing the issue. You can use https://imgbb.com for screenshots

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    I have same problem ahref show you are not using canonical url
    Pls check my website Result Bharat

    Hello,

    @india Sorry for the inconvenience this issue may have caused you.

    Could you confirm if you have already followed Michael’s advice on this issue? Please also provide a screenshot where you see this error message. You can use this tool https://imgbb.com and share the link here to investigate further.

    Thank you, and looking forward to helping you.

    Hello,

    I checked your site and there seems to be an issue with all your URLs. They all seem to be missing the protocol part(https:), here is a screenshot: https://i.rankmath.com/11PoJC

    Looking forward to helping you

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this ticket.