[Bug]Incorrect data

  • Rankmath is combining keyword data for every property. So every keyword from all my other properties are displayed inside the search console overview of rankmath.

    Between March 12 and March 16 rankmath shows that there were no impressions, clicks, rankings dropped like the site was penalized/ set to noindex. The real Search console does not show such drop.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi Florian,

    Thanks a lot for your query and we are so sorry about the trouble this must have caused.

    Please head over to WordPress Dashboard > Rank Math > General Settings > Search Console

    Then, hit the “update cache manually” button once.

    That should do the trick and pull ALL your data from your actual Search Console profile.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Sounds good, does not work.

    Hello,

    Thanks for getting back to us.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Also every keyword from all my other properties are displayed inside the search console overview. I don’t think you need access to my site to replicate this issue. I don’t mind enough having incorrect data displayed, just thought you might want to check on your end.

    Hi Florian,

    Thanks for the reply.

    I am afraid that we cannot replicate the problem our test environments which suggests that the issue could be related to your environment.

    Please let us know if we can offer any other help 🙂

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

The ticket ‘[Bug]Incorrect data’ is closed to new replies.