Bug found

#53659
  • Actually i have found a bug in rankmath.. I always make sure that my all paragraphs are short and rankmath also assigns green tick but as soon as i update or publish the post it become red tick on using short paragraph but in the posts section the score remains good but inside the post it shows a decreased scoe due to not using short paragraphs.

    • This topic was modified 9 months, 1 week ago by Facts Pedia.
Viewing 15 replies - 1 through 15 (of 19 total)
  • Hello,

    I tried again to log in but again I was not able to.

    Should I have same schema variables in post and page (seo title and seo description)

    About that, yes, you can do like that; or even you could customize each post and page title and description, just as you prefer.

    And what do you mean by vars ?

    With vars I mean variables (%seo-title%, %seo-description%…)

    Looking forward to help you.

    I don’t know why you were not able to login but i have changed the link you may attempt to login

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Check the articles like कैंसर के लक्षण, shilajit ke fayde etc. You will see a different score in posts dashboard but when you edit the post you will see different score. Just press enter in any paragraph and press backspace space the score will change and when you update the post the score becomes less than that of what you updated.

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    For your home page, Rank math has the description perfectly set. You can test it yourself with this tool: https://rankmath.com/tools/seo-analyzer/

    In the issue of different seo score, this should not have you worried, some of the tests only run when you actually open the post. I was unable to continue further testing since your login link expired and I can no longer access your site.

    Looking forward to helping you.

    ​​​​​​​

    I have updated the login url please check it hasn’t expired. If rankmath is working correctly then why my seo meta description shows wrong on Google. Have you made any changes in my website then please let me know. My login link is live. What further you want to test ?

    Please check soon else login link will expire in 2 days

    Hello,

    Thank you for contacting Rank Math today.

    I have checked your site. Yes Rank math has set the description right for your page. You can test it also using the Facebook debugger.
    The description showing on google is being generated by a conflicting plugin, the Schema & Structured Data for WP & AMP plugin. I have attached a screenshot in the sensitive section of the description being generated even with Rank math disabled, please check. I’d suggest you get in touch with the plugin developer to help you disable this functionality.

    Id also like to recommend you on the same plugin to disable Rank math Schema module to avoid possible conflicts.

    I did not change anything on your site, I am using the Healthcheck & Troubleshooting plugin.

    Hoping this helps you. Thank you.

    ​​​​​​

    I have contacted the plugin developer and I wanted to know that what should I do now . Are you telling me to disable schema module of rankmath ?

    Where is my title ? Is it caused by that plugin only or by rankmath ? Please check the screenshot below.

    https://snipboard.io/lgMcQY.jpg

    When i scanned my website on facebook debugger. It showed me 2 errors. Please check the screenshot. What should i do to fix this error ?

    https://snipboard.io/4v3Ea9.jpg

    Michael what is the solution of this ?

    Hello,

    Where is my title ? Is it caused by that plugin only or by rankmath ? Please check the screenshot below.

    This is an amp page, I recommend you to use one of our supported AMP plugins:
    AMP for WordPress, AMP for WP, WP AMP Ninja, AMP on WordPress – weeblrAMP CE, AMP for WooCommerce, WP AMP.

    Rank Math will work out-of-the-box or with just some tweaks on those plugins and your issue will be fixed at the moment.

    Concerning Facebook debugger errors

    fb app id: please head over to Rank math > Titles & Meta > Social meta then anter your fb data: https://i.rankmath.com/c4pfm0

    missing og: please head over to Rank math > Titles & Meta > Global Meta and add an image for the Open Graph thumbnail

    Looking forward to help you.

    This is an amp page, I recommend you to use one of our supported AMP plugins:
    AMP for WordPress, AMP for WP, WP AMP Ninja, AMP on WordPress – weeblrAMP CE, AMP for WooCommerce, WP AMP.

    Rank Math will work out-of-the-box or with just some tweaks on those plugins and your issue will be fixed at the moment.

    I already use amp for wp but why my title is not showing. Is it due to amp for wp plugin ? Should I contact amp for wp developer ?

    missing og: please head over to Rank math > Titles & Meta > Global Meta and add an image for the Open Graph thumbnail

    I have already done this but why it showing this error ? You may check my admin panel. I am providing login url in sensitive data section.

    fb app id: please head over to Rank math > Titles & Meta > Social meta then anter your fb data: https://i.rankmath.com/c4pfm0

    I think I don’t need this leave it.

    Check my admin panel and please tell that why my meta description is showing wrong still. Tell me the exact cause of the problem please so that I can tell this to the developer of structured data and schema for wp and amp Plugin.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Why my meta description is showing wrong and why in amp my title is not showing. Please check the issue. I talked to the developer of the schema plugin they told me something. I have attached the screenshot in the sensitive data section. Please check my admin panel to look for possible error.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)

The ticket ‘Bug found’ is closed to new replies.