Automatic redirection works to some extent.

#408435
  • Automatic redirection works on English URLs, but not on Italian ones.

    I change a url, but the Italian url receives 404 error.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello,

    Thanks for contacting us and sorry for any inconvenience that might have been caused due to that.

    I can check that you are using TranslatePress to translate your site. TranslatePress creates the translate pages dynamically. The Auto Post Redirect will only work when you change the URL of the post/taxonomy and it will create the redirection only for that post, not for its translated version.

    Since the translated pages don’t exist in the backend, you can’t change their URL to create the automatic redirection and will have to create the redirections for the them manually.

    Hope this helps. Let us know if you need any other assistance.

    Will I fix the problem when I get the paid version of Translatepress?

    Hello,

    The paid version of TranslatePress also translates the site the same way. So upgrading to the paid version is not going to solve the automatic redirections. You will still have to create the redirections manually for the translated URLs.

    Hope this helps. Let us know if you need any other assistance.

    Very bad. Then I have to contact Translatepress.

    Hello,

    Yes, you would need to contact Translatepress and ask what would be a workaround for this. Do let us know how this goes. We are here to help you.

    In the meantime, please do not hesitate to let us know if you need our assistance with anything else.

    Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    The login details you have shared in the sensitive data section are for your staging site only.

    Could you please confirm if you’re still unable to log in to your site? You can try getting in touch with your web host to assist you with your site’s access.

    Let us know how this goes.

    Thank you.

    I’ve solved. It was 3 rules added on Cloudflare.

    Hello,

    I am glad that the issue has been resolved.

    If you have other issues or questions in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this ticket.