AMP Plugin do not support

  • Today, I see as warning that RankMath is not supported with AMP pluging??
    Is that true?
    If yes, then what next?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you please let us know the specific AMP plugin that is reporting this error so that we can investigate further?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    https://wordpress.org/plugins/amp/

    Im talking about above plugin

    Hello, Any updates on this?

    Hi Aniket,

    Thanks for the follow up.

    I have just installed this plugin but no warnings are reported on my end.
    Could you please check if your site is running on an older PHP version?

    Let me know how this goes. Thank you.

    Running PHP version: 7.0.33-0+deb9u6

    This si the PHP Version

    Hi I am having dupliacate amp cannonical issues because of your plugin

    Hi @aniketthanage

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/


    @420dc
    could you please install a different AMP plugin and check if the problem is still reproduced?

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Aniket,

    I do not see any warning.

    Can you please share the URL where you are seeing the warning as well as a screenshot of the warning?

    Our plugin is 100% compatible with the official AMP and other popular AMP plugins.

    We look forward to hearing back from you.


    @420
    , we have replied to your own ticket where to be clear we did not find any duplicate canonical tags. We request you not to hijack someone else’s ticket.

    Thank you.

    Hello, can you check again, I have activated the AMP plugin and error is

    Please login and check error under the AMP plugin

    Information
    Arbitrary JavaScript is not allowed in AMP. You cannot use JS <script> tags unless they are for loading AMP components (which the AMP plugin will add for you automatically). In order for a page to be served as AMP, the invalid JS code must be removed from the page. Learn more about how AMP works. As an alternative to using custom JS, please consider using a pre-built AMP functionality, including actions and events (as opposed to JS event handler attributes like onclick) and the amp-bind component; you may also add custom JS if encapsulated in the amp-script.

    If you remove the invalid markup then it will not block this page from being served as AMP. Note that you need to check what impact the removal of the invalid markup has on the page to see if the result is acceptable. If you keep the invalid markup, then the page will not be served as AMP.

    Invalid markup
    <script … >
    Element attributes
    type text/javascript
    Element name
    script
    Parent element
    body
    Text content
    Sources

    Hi Aniket,

    I am afraid that is not caused by Rank Math. Your AMP error-index says it could be due to any one of the 5 plugins listed.

    Rank Math only adds canonical and schema info to your AMPs. We do not handle anything else.

    Moreover, I do not see any issue in the online validation tool:
    https://i.rankmath.com/J9tUBG

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Ok, Thanks for the update. Any anything needed. I will get back to you.

    Hi Aniket,

    I am glad that this info was helpful 🙂

    Feel free to contact us should any other issues come up.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)

The ticket ‘AMP Plugin do not support’ is closed to new replies.