Alt Tag not filling

#155733
  • Hi !

    I activated the Alt tag to be automatically filled, but it’s not working :
    – The SEO Analysis says I still have missing texts.
    – I checked with the Inspector on the home page & I do have some empty alt tags.

    Thanks for your help,
    Vianney.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello,

    Thank you for contacting Rank Math, and sorry for any inconvenience caused.

    Have you added the Alt attribute format?

    If you have already added the alt attribute format and the issue persists, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress & FTP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?
    Also, I put %filename% in the Alt tag.

    Thank you.

    Hello,

    Thank you for that additional information, and sorry for the delay.

    We would like to further investigate this issue, but it seems that the login credentials you have provided are no longer working or incorrect. Please see the screencast in the designated Sensitive Data section.

    Could you please check?

    Thank you, and we really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?
    Sorry, the password was changed, I updated it in the sensitive details.

    Ok, now you can login through :
    https://thefield.team/wp-login.php?wle=ZTNhYjliZGNmYWY4NmU5N2FkNGUwNGEyMmEyOTdmNTkyZWFkMTQ0YmFlZTRkZjg5

    Thank you.

    Hello,

    Thank you for the update, and sorry for the delay.

    I’ve checked your site, and it seems that the images you are referring to are Avatar images. If not, could you please confirm how are you adding those images to your website?

    However, our PRO version has an option to add Alt attributes for your avatar images. Please check the link below for more information and Image options we offer:
    https://rankmath.com/kb/image-seo/#9-add-alt-attributes-for-avatars-pro

    I hope that helps. Thank you, and please don’t hesitate to contact us if you need further assistance.

    Hello,

    No, it’s actually a picture loaded from an ACF field, not an avatar then.
    So it’s a “normal” image I would say.

    Hello,

    I am afraid Rank math may not add alt tags to images added through custom fields but through WordPress Content editor.

    You would need to add your image through WordPress editor for the alt attribute to be added automatically.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Ok, i didn’t know that. Thanks for the explanations !

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this ticket.