Additional Pins not showing

  • Hi, I’ve added a number of additional pins for my articles, but they won’t show. The only one that appears is the one I’ve added to the post itself.

    I’ve tried using the Tailwind and Pinterest extensions … for both Chrome and Firefox.
    I’ve tried the Social Pug Pin button (Grow by Mediavine) on my post.

    No new plugins have been installed. Can you suggest a solution?

Viewing 1 replies (of 1 total)
  • Hi Linda,

    Thank you for getting back to me.

    We have tested this and it seems to be an issue on Pinterest’s side. We also see reports of the issue on various forums online.

    Rich Pins require a set of OpenGraph meta tags to work (https://developers.pinterest.com/docs/rich-pins/articles/) and those are added automatically by Rank Math when selecting one of the Rich Snippet types supported by Pinterest: Article, Product, or Recipe. By looking at the source code of your page you can confirm that the meta tags are there, and even the Rich Pins validator tool does not show any error.

    To get Rich Pins to show up, you also need to apply and validate your domains once, as described here: (but you mentioned that you already verified that)
    https://developers.pinterest.com/docs/rich-pins/overview/

    If your site is validated and the testing tool does not show any error, then the Rich Pins should show up correctly. If they don’t, I would advise contacting the Pinterest support team about the issue.

    Hope that helps. If there’s anything else, please let me know.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 1 replies (of 1 total)

The ticket ‘Additional Pins not showing’ is closed to new replies.