Add image Alt not working

  • Hi,
    As the ticket title, add image Alt not working, i have already setup to auto add the missing image Alt, but it doesn’t work. How to fix it?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you please share a link to one of the affected pages on the sensitive data section so that we can check this and advise further?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi there,

    Thanks for the follow up.

    I have been able to reproduce this problem after a couple of tests on my end. This has been raised with our dev team for closer investigation and we will be getting back to you in a short while.

    We appreciate your patience. Thank you.

    Hi Chong,

    I appreciate your patience.

    Please note that Rank Math only adds the missing alt and title text to images added using the post editor of WordPress/WooCommerce.

    We do not add them to the images added using your theme or custom code.

    You will have to get in touch with your theme provider and ask them to add the code to turn your product title into an alt text for your product featured images.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    last reply ‘Please note that Rank Math only adds the missing alt and title text to images added using the post editor of WordPress/WooCommerce.’

    yes, i do use the post editor of wordpress/woocommerce but it can’t work.

    When i done the SEO Analysis, at the result on Image ALT Attributes, i click on the ‘How to fix’ button, there is nothing show out! Is the normal? or i need to reinstall again the plugin?

    Hello,

    The SEO Analysis only checks for your homepage. Please test your homepage and view the source code. You will find that your homepage is missing alt text on images. You can fix that either via your page builder or by asking for help from your theme developer.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this ticket.