A value for the logo field is required.

  • I have seen on many pages that I have structure data issues.

    A value for the logo field is required.

    I have a logo in the settings but still getting its error.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Assuming you are using the latest version of all the plugins and the themes (please update if not yet), it would seem like a conflict with one of the plugins or the theme you are using.

    To determine that, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Please let us know if you find the culprit.

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Looking forward to helping you.

    Hi,

    I have checked but it seems that the logo is appearing in the schema code (you can check with F12) so maybe something with the syntax code is wrong? because in the code you can see the logo URL in the Schema.

    • This reply was modified 3 months ago by B4 Gamez.
    • This reply was modified 3 months ago by B4 Gamez.

    I have found that the plugin Schema & Structured Data for WP & AMP made the issue so I disabled it and it’s working now. thanks

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this ticket.