A few Issues

  • We have a few issues we are trying to resolve:

    1. WooCommerce Products are showing as “articles” not “products”
    2. Need to add author to products
    3. Need to add date published to products

    Is there a function we can add that would resolve this as it doesn’t seem to pick up the correct info from the RM settings.

    https://i.imgur.com/WHHycMB.png

    Thank you in advance.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello,

    Thank you for contacting Rank Math today.

    I checked a number of products from your store page and the seem to have product schema. Could you please share any specific URL that we can check for this issue.

    Looking forward to helping you. Thank you.

    ​​​​​​

    We had to manually add some code in functions.php to actually hardwire the author, but it still doesn’t appear correctly in LinkedIn for Author or Published Date … any ideas how to fix?
    https://i.imgur.com/gdgmTB2.png

    Also, the Sitelinks don’t seem to be correct, url looks strange:
    https://i.imgur.com/ut3desW.png
    https://i.imgur.com/w5xT0ry.png

    All products have the same settings and results.

    Last issue, is that when we add either FAQ or Rich Snippets to the products (there are none in place currently as it was displaying wrong), this overrides what is shown as the description in the search results, if we add (for example) 5 x FAQ or Q/A into the footer of the a product, the search results show one of these 5 x Q/A as the description, it overrides what we have manually set as the description, how can we force it to show the description we set?

    Thank you in advance.

    Hello,

    Thank you for the follow up.

    1. The data added to linked in is usually through the opengraph meta tags. In your case you have duplicate opengraph tags, one by Rank math and another by Social Snap plugin v1.1.9. Please use only one plugin to generate met to avoid conflict. If you wish to use social meta from your other plugin and not Rank math , you can use this filter: https://rankmath.com/kb/filters-hooks-api-developer/#remove-opengraph-tags to remove opengraph data added by Rank math.

    2. For the sitelinks, if you are referring to the URL template value, that is exactly how it is supposed to be. Rank math only adds the Sitelink meta under your website type.

    3. You should first check if your title/description is properly set up in the page source: https://i.rankmath.com/HwXR1o . You can use this tool for the same as well: https://www.heymeta.com/

    ​Do note that if everything’s fine and Google still decides to show a different meta title/description for your search keyword, there is nothing you can do as Google sometimes ignores the custom meta info altogether and show something from the page’s content that matches the search intent better.

    The best you can do is optimize your meta tags to try and match the intent of the search/keyword.

    You can read more about it here

    https://support.google.com/webmasters/answer/35624?hl=en

    This section sheds light on that:

    Why the search result title might differ from the page's <title> tag

    Hope that helps. If you have any further question(s), please let us know.
    ​​​​​​

    Thank you.

    We added the code into functions to disable the RM og tags as you suggested but it doesn’t look like it actually does anything as none of the tags change when we test …

    Code is still in place now.

    Hello,

    The code is actually removing the social meta added by Rank math. It however seems one of the plugins is conflicting with this functionality. You can check the screencast I have added in the sensitive section where the social meta is not there when only Rank math is active with your child theme. When social snap is activated, only then is the social meta, as defined by the social plugin, is added to your page.

    To determine which plugin is causing the issue, please follow this troubleshooting guide: https://rankmath.com/kb/check-plugin-conflicts/

    Please let us know if you find the culprit.

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Looking forward to helping you.

    Thank you for your help so far, and sorry to be such a pain.

    We have no choice except to use an additional plugin to modify and manually add some missing schema data, how can we disable Rank Math from inserting ANY schema data?

    Essentially we want to use RM for everything else except Schema, is there a way to disable this entirely?

    Hello,

    Just head over to Rank math dashboard and disable the Rank math Schema module.

    Hope that helps. If you have any further question(s), please let us know.

    Thank you.

    Ah, yes! Thank you, forgot about that area.

    Hello,

    We are glad we could assist.

    Do you wish to mark this as resolved.

    If you have any further question(s), please let us know. Thank you.

    Yes, we can mark this as resolved, thank you for the help. If anything else crops up we’ll open a new ticket. Thanks again.

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 11 replies - 1 through 11 (of 11 total)

The ticket ‘A few Issues’ is closed to new replies.