500 error after updating

#8653
  • I updated the plugin and now the entire site is 500 whitescreen. Manually deactivated the plugin but nothing has changed. I’m totally stuck.

    • This topic was modified 3 years, 3 months ago by Chris.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Same problem here. Seems Rank Math is doing something with the .htaccess so it won’t work anymore. Here it happened after activating the “Redirect Attachments” option, the site instant went into an Internal Server Error.

    Solution for now: Use the .htaccess backup and make it not writeable anymore via FTP. Otherwise Rank Math will overwrite it again and again and again.

    Hope this problem gets solved as soon as possible since it’s well known for a few months now:
    https://wordpress.org/support/topic/internal-server-error-566/

    Update. My .htaccess file was totally trashed.

    Let me know if you need a before and after .htaccess, RankMath

    And it will get trashed again since RankMath keeps overwriting it

    Yeah I went to re-enable stripping the product base and it 500’d again immediately. Had to restore the backup again.

    Thanks for your help Thomas I appreciate the offer, but I think I’ve got things figured out now mostly. Initially my .htaccess file was completely missing anything in <>, like </IfModule>. The second time, I couldn’t find a difference with diffchecker, but restoring the backup RM created worked. Weird. For now I’ve made my htaccess file read only. Thanks for that tip.

    You’re welcome. Nontheless RankMath need to figure out what’s wrong with overwriting the .htaccess in that completely weird manner. As long as this happens over and over again and the .htaccess is read only, other plugins like WP Fastest Cache might get broken too.

    Hi Thomas and Chris,

    Thanks for getting in touch and sorry for the inconvenience caused.

    I am glad that you were able to fix this issue, I cannot reproduce this issue myself but your findings have been submitted to our dev team and we will be digging deeper into this issue and get back to you.

    We appreciate your patience and understanding in this.

    Well, it’s not really a fix, it’s more a temporary solution. I don’t think it’s a very good idea to have a wordpress instance running with a read only .htaccess. ­čśë

    Thanks for your support, Michael.

    Hi Thomas,

    Thanks for the clarification.

    We will get back to you in a short while.

    Thank you.

    Problem still appears in 1.0.27.3

    For me the latest update solved the issue. Works like a charm, even after setting the .htaccess back to write access

    Hi Thomas,

    Thanks for the follow up.

    I am glad that this update has fixed the issue for you.
    Bastian, please clear your cache and check again.

    Let us know how this goes. Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)

The ticket ‘500 error after updating’ is closed to new replies.