404 on /sitemap_index.xml

  • Hello folks,

    every now and then, the google crawler is getting a 404 response on the /sitemap_index.xml link. It’s the only link, getting a 404. At the same time /sitemap-pt-****-2016-06.xml is accessible. Whenever I click on /sitemap_index.xml the url is working just fine. Goin’ to settings/permalinks saving again doesn’t seem to get rid of this error. It’s the only URL throwing a 404 error. Since it’s a the sitemap URL it’s an important URL.

    Please have a look at this issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    This is very odd and unexpected, could you please let us know how often this happens so that we can advise further?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello Michael,

    Thanks for your response. Here is a log excerpt. It’s working fine at the moment again. Like stated above, I’m pretty sure it will appear in a couple of days.

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    15/11/2019 09:44:38 (1 day 1 hour ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    15/11/2019 09:37:27 (1 day 1 hour ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    15/11/2019 05:56:08 (1 day 5 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    15/11/2019 05:43:19 (1 day 5 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    14/11/2019 18:03:47 (1 day 17 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    14/11/2019 13:54:45 (1 day 21 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    14/11/2019 13:40:23 (1 day 21 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    14/11/2019 11:02:37 (2 days ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    14/11/2019 05:22:43 (2 days 5 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    14/11/2019 04:13:47 (2 days 7 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    04/11/2019 19:24:49 (11 days 15 hours ago)
    IP: 66.249.**.** Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Google, United States tried to access a non-existent page www.******.***/sitemap_index.xml
    04/11/2019 18:19:40 (11 days 17 hours ago)
    IP: 66.249.**.**Hostname: crawl-google
    Human/Bot: Bot
    Type: 404 Not Found

    Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    I’m facing a similar issue. Is there any update re: resolution?

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    This problem could have something to do with caching of the sitemap file on your end. Could you please disable any caching plugins that you have installed and let us know if the problem is still reproduced?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hi. I’m not sure why but the sitemaps are showing on Google again and they are updating on the Rankmath side as well.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this ticket.