404 Monitor Won't Activate (Indefinite Loading Icon)

  • Hi, issue summed in title. Everything else in RankMath appears to be working.

    When activating the 404 Monitor on the RankMath dashboard (latest version), it shows the circular loading icon but never does anything more.

    Refreshing the page after any amount of time shows that the feature is still deactivated.

    Any clues on what might cause this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Corey,

    Thanks a lot for your query and we are so sorry about the trouble this must have caused.

    Could you please ask your web hosting provider for your error and debug log so we can try and diagnose the issue?

    We look forward to helping you.

    I have access to Apache. No items in the error.log at the relevant timestamps. Three items in transfer.log.

    71.239.174.122 - - [07/Jun/2019:12:44:45 -0400] "GET /wp-json/rankmath/v1/savemodule/ HTTP/1.1" 404 113 "https://northcutt.com/wp-admin/admin.php?page=rank-math" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.80 Safari/537.36"
    71.239.174.122 - - [07/Jun/2019:12:44:45 -0400] "GET /wp-json/rankmath/v1/saveModule/ HTTP/1.1" 301 - "https://northcutt.com/wp-admin/admin.php?page=rank-math" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.80 Safari/537.36"
    71.239.174.122 - - [07/Jun/2019:12:44:45 -0400] "POST /wp-json/rankmath/v1/saveModule HTTP/1.1" 301 215 "https://northcutt.com/wp-admin/admin.php?page=rank-math" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.80 Safari/537.36"

    Could be a permissions thing?

    Hi Corey,

    Thanks for the follow up.

    I am not sure that this is related to some permissions.
    I would suggest that you enable debugging mode and then get in touch with your host so that they can share a copy of the debug log to help in isolating the cause of this issue.

    I am looking forward to helping you. Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)

The ticket ‘404 Monitor Won't Activate (Indefinite Loading Icon)’ is closed to new replies.