404 errors

  • Hello,

    I have a question re 404. I am running my page through Screaming Frog and receive 2 x 404 error while in my RankMath 404 Menu, I have 51 x 404 error and the only option I have is ‘delete’. When I delete, the errors appear again the next day.
    My page is live but has no traffic yet, and no outside links/ backlinks from blogs or old posts etc as we’re just starting out.

    Do you mind checking what the issue is here?

    I appreciate your help.

    Kind regards,
    Kat

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    You need to enable the Redirections module via the Rank Math dashboard for the redirect option to appear under the 404 page. I have enabled this option for you and you can now redirect the 404s.
    Please take a look at this guide for more info on this: https://rankmath.com/kb/fix-404-errors/

    I hope this info helps. Thank you.

    ​​​​​​​

    Thanks Michael,

    I have just checked and now there is no count anymore. I only see URI and Access Time but not Referrer or Agent.

    Can you please check again.

    Also, do you have any answer to why RankMath shows all these 404s while the page has not yet been promoted and no backlinks?

    Thank you,
    Kat

    Hi Kat,

    Thank you for the question and sorry for missing that earlier.

    Referrer and user-agent appear correctly for me.
    Most of the logged errors relate to media files that might have been deleted which your theme might still be referencing while loading your pages.
    The rest are post slugs that you might have renamed which may trigger a 404 when typed on the browser.

    I hope this info helps.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this ticket.