404 Error Sitemaps

#133325
  • Hi, I have a 404 sitemap error again and it is eating into my sessions. have a look at the attached screencast. Thank you

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Looking at your site, I see that it has the index tag.
    https://i.rankmath.com/0oubrv

    Using an SEO site checker, it is showing there is no noindex tag.
    https://i.rankmath.com/ihX4Hd

    That means Rank Math is functioning correctly.

    I would suggest checking with GSC forum as well to see if this is a common issue on their side or not.

    I hope this resolves your issue.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Can you at least try and troubleshoot where the issue might be? I will also, on my side try publishing a few more articles to see if Google can recrawl my site and see what happens in the next few days. Thank you

    Hello,

    Sure, we would love to check.

    1. Please share the URLs that Google is saying have a noindex. Please note it is normal to have noindex on tag/author/date archives.

    2.Share the URLs showing 404. If those URL really do not exist, you should consider redirecting them to a more relevant page on your website:
    https://rankmath.com/kb/setting-up-redirections/

    Hope that helps.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    I have added a screenshot. Please, check it out. Also, I have added login details for you to log in, and troubleshoot the issue. My traffic is down 50%. Thank you

    Hello,

    Your video shows you are inspecting the sitemap URL. The sitemap is set to noindex intentionally. This is because the sitemap is only meant to be crawled, not to be shown on search results.

    The issue with your sitemap is likely due to caching(check the screenshot I have added in the sensitive section), which normally makes the sitemap not to update as expected and lead to 404. You should always exclude the Sitemap files of the Rank Math plugin in your caching plugin. To do so, please follow this article: https://rankmath.com/kb/exclude-sitemaps-from-caching/

    That should fix the issue. Please let me know if that does not. We are here to assist.

    I have done that but still no solution. In fact, I dont use W3TC. I am using Breeze, Cloudways Vultr HF and Varnish. I have sitemaps excluded in both Varnish and Breeze but still the solution persisists. Can you check on it again? Perhaps some setting or code in the plugin misbehaving? Thank you

    Hello,

    Thank you for following up.

    I’ve checked your sitemap, and it’s already showing fine without a 404 error. The code from W3TC from your sitemap is also removed from the page source.

    If you’re still getting the noindex error in GSC for your sitemap, it is normal as sitemaps are set to noindex intentionally, as my colleague mentioned.

    We also suggest only submit your main sitemap yourdomain.com/sitemap_index.xml to GSC and give Google some time to recrawl your website.

    I hope that helps. Thank you, and please don’t hesitate to contact us if you need further assistance.

    Hi,

    Once again, I confident that my sitemap has anomalies despite your assurance. I have been blogging hands-on for the past 3 years and I think I am at a level where I can know when things are not going okay.

    It has been close to 2 weeks so far since I first raised these issues.

    In as much as the support has been trying to help, I have not gotten concrete help that helps solve the issue.

    1. My sitemap still shows very old content and doesn’t pick new updates. It is the same old info that the sitemap feeds to Google during crawling I guess. For instance, (a) none of the categories in the sitemap exists on my site! The categories on my site and the ones on my sitemap are very different. The ones on my site are ones that existed 4 months ago!

    (b) The sitemap says 80 posts, when opened there are 119 listed and yet on my website are 128!

    2. I switched off tags for crawling but despite that, I still see tags in my sitemap even after deleting the sitemap and adding it again. I am sure google crawls it too. Sometimes back, when I toggle tags off, it disappeared from the sitemap as well. I deleted all the tags for thin SEO reasons and switched off tags from Rankmath.

    3. The sitemap still says there is a no-index tag when inspected to this day! It never used to be the case before whenever I did inspect it; countless times. Before when I did inspect the sitemap it would give a green notification saying it is indexed.

    Note: I have emptied caches several times, excluded sitemaps from the cache both Breeze and Varnish, deleted then saved it, saved it from settings…Permalinks and all other troubleshooting measures from your website.

    Can someone try to troubleshoot maybe there is a broken or incompatibility issue between the Rankmath plugin and something else maybe, or just anything that can help?

    Hello,

    I can no longer see any issue with your sitemap not updating from my end. I accessed your site and:

    >> There is no tag sitemap included.

    >> I created a test post and refreshing the sitemap on my browser updates the post just fine.

    Please check the NEW screencast I have added in the sensitive section.

    Would you please try checking your sitemap in an incognito browser to confirm if your sitemap is not browser cached?

    Please check and let us know. Really looking forward to assisting you.

    I have checked and it seems to work for now. Let me observe it for two days or three before I mark the string as resolved. Thank you @Michaeldavis

    Hello,

    Glad to assist you.

    Let us know if you have any further questions on the same.

    Thanks

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this ticket.