Sitemap issue

  • Hello,

    I recognised in Search console, that my sitemap suddenly stopped working, I was getting a 404 error. Updated permalinks and Rankmath, but now I’m getting a blank page. I also disabled plugins, but the problem remained. Help me please. What should I do to get my sitemap back?

    Thank you

    • This topic was modified 1 month ago by  Adamonero.
    • This topic was modified 1 month ago by  Adamonero.
Viewing 5 replies - 16 through 20 (of 20 total)
  • Hello, should I remove RM and try to install again? IT’s been quite a while now, that my sitemap isn’t working. Will I get any problems if I do that? Any ideas, what could I still do?

    Thank you

    Hello! Any news regarding my issue? 🙁

    Hello,

    Sorry for not following up quickly and any inconvenience that might have been caused due to that.

    I saw, you’ve been in my FTP account, and I started to receive 503 errors. Do you have any idea, why I’m getting these?

    Yes, I had logged into your site to see if any errors are logged in the debug.log file which might be preventing the Sitemap from working well. But I found no error which could conflict with the Sitemap functionality.

    If you view page source you’ll see the sitemap. So sitemap is generated on your site and Google will also fetch it. The only reason why its showing blank page is because of the encoding errors in site_url/main-sitemap.xsl file (please see the screenshot I added in the sensitive Data Section). If you see any Sitemap errors in the Google Search console then please let us know.

    And to further debug the encoding errors in main-sitemap.xsl file, we’ll be needing your site’s admin & FTP access. The Admin link you added in the Sensitive Data Section is not valid anymore. Can you please check that and post the correct link?

    Looking forward to helping you. Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Search Console became green now.

    Thank you: Beata

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 5 replies - 16 through 20 (of 20 total)

The ticket ‘Sitemap issue’ is closed to new replies.